В
Все
Б
Биология
Б
Беларуская мова
У
Українська мова
А
Алгебра
Р
Русский язык
О
ОБЖ
И
История
Ф
Физика
Қ
Қазақ тiлi
О
Окружающий мир
Э
Экономика
Н
Немецкий язык
Х
Химия
П
Право
П
Психология
Д
Другие предметы
Л
Литература
Г
География
Ф
Французский язык
М
Математика
М
Музыка
А
Английский язык
М
МХК
У
Українська література
И
Информатика
О
Обществознание
Г
Геометрия
16Milochka16
16Milochka16
17.07.2022 15:03 •  Информатика

Написать программу, которая позволяет ввести 12 значений. далее программа выводит на экран два числа. в одно число нужно записать сумму чисел меньше 100, а в другое сумму чисел меньше 100. то есть при вводе программа должна определить какие значения ты вводишь и разбивает значения на 2 группы, меньше 100 и больше 100, а далее суммирует числа в каждой группе и выводит ответ.

Показать ответ
Ответ:
Liza6895
Liza6895
07.10.2020 01:43

program raf105;

var

 num,sum1,sum2: integer;

begin

 writeln('Вводите 12 чисел по очереди');

 for var i:=1 to 12 do

 begin

   readln(num);

   if num < 100 then sum1:= sum1 + num;

   if num > 100 then sum2:= sum2 + num;

 end;

 writeln('Сумма чисел меньше 100: ',sum1);

 writeln('Сумма чисел больше 100: ',sum2);

end.

PascalABC
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота