В
Все
Б
Биология
Б
Беларуская мова
У
Українська мова
А
Алгебра
Р
Русский язык
О
ОБЖ
И
История
Ф
Физика
Қ
Қазақ тiлi
О
Окружающий мир
Э
Экономика
Н
Немецкий язык
Х
Химия
П
Право
П
Психология
Д
Другие предметы
Л
Литература
Г
География
Ф
Французский язык
М
Математика
М
Музыка
А
Английский язык
М
МХК
У
Українська література
И
Информатика
О
Обществознание
Г
Геометрия
Anna1011qpqq
Anna1011qpqq
11.03.2022 04:07 •  Информатика

Написать программу,которая последовательность чисел, разбивает на два подмножества с одинаковой суммой. Количество чисел в подмножествах может отличаться. Точное разбиение.

Показать ответ
Ответ:
karinasoskova
karinasoskova
05.10.2022 05:47
Program fakt;
var
   n,i,z:integer;
begin
   readln(n);
   z:=1;
   for i:=2 to n do
      z:=z*i;
   writeln(z);
end.

Если программу написать так, то максимальный факториал, которой мы сможем вычислить - 12. Можно integer изменить на real, тогда чуть больше сможем вычислить. Так же можно вычислить через массив, тогда где-то 3000 мы сможем получить.

Если же ввести больше 12 в этой программе, то получится переполнение переменой, из-за чего число пойдёт "по кругу". Т.е. мы получим не 3 000 000 000, а -1 000 000 000, т.к. максимальное число у integer - примерно 2 000 000 000
0,0(0 оценок)
Ответ:
Валерик2281
Валерик2281
10.02.2023 21:32
PascalABC.NET 3.3.5, сборка 1659 от 09.04.2018
Внимание! Если программа не работает, обновите версию!

begin
  // структура строки
  // день время канал вид название(возможно, многословное)
  // цель: удалив "канал" (третье слово), найти совпадающие строки
  var ms:=ReadAllLines('TV.txt');
  ms.PrintLines; // чтобы было понятно содержимое файла
  Writeln;
  var d:=ms.GroupBy(s->(s.ToWords[:2]+s.ToWords[3:]).JoinIntoString(' '))
      .Select(t->(t.Key,t.Count)).Where(t->t[1]>1).Select(t->t[0]);
  if d.Count=0 then Writeln('Искомые передачи отсутствуют')
  else
    foreach var s in d do begin
      var key:=s.ToWords.Take(2).JoinIntoString;
      ms.Where(t->t.ToWords.Take(2).JoinIntoString=key).Printlines;
      Writeln
      end
end.

Пример
Понедельник 09:00 Первый Новости Новости на Первом
Суббота 19:40 Первый Фильм Кин-дза-дза!
Среда Первый 07:15 НТВ Мультфильм Трое из Простоквашино
Четверг 19:40 Первый Фильм Кин-дза-дза!
Вторник 09:00 Первый Новости Новости на Первом
Понедельник 12:00 Первый Новости Новости на Первом
Пятница 16:40 Россия-1 Мультфильм Трое из Простоквашино
Суббота 19:40 Россия-1 Фильм Кин-дза-дза!
Среда 09:00 Первый Новости Новости на Первом
Четверг 09:00 Первый Новости Новости на Первом
Суббота 19:40 НТВ Фильм Кин-дза-дза!

Суббота 19:40 Первый Фильм Кин-дза-дза!
Суббота 19:40 Россия-1 Фильм Кин-дза-дза!
Суббота 19:40 НТВ Фильм Кин-дза-дза!
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота