Написать программу, которая по соответствующей по порядковому номеру на картинке рисует , закрашивает и подписывает фигуру. предусмотреть критический случай. Ёлочка, сердце, цветок, пирог
writeln('Банан красного цвета стоит 2500, банан синего цвета стоит 3000, банан черного цвета стоит 3700');
writeln('Сколько купите бананов '); readln(n);
writeln('Введите цвет бананов '); readln(st1);
if (st1='Красного') or (st1='красного') or (st1='Красный') or (st1='красный') then sum:=3000*n;
if (st1='Синего') or (st1='синего') or (st1='Синий') or (st1='синий') or (st1='Синей') or (st1='синей') then sum:=2500*n;
if (st1='Черного') or (st1='черного') or (st1='Чёрного') or (st1='чёрного') or (st1='Черный') or (st1='черный') or (st1='чёрный') or (st1='Чёрный') then sum:=3700*n;
По условию данной нам задачи сказано, что общее число купленных персиков равно неизвестной а, также после покупки количества а персиков мы убираем от количества а количество b персиков, так как они оказались ещё зелёными. Следовательно у нас имеется количество съедобных персиков равны а - b. По условию задачи дано, что количество съедобных персиков было разделено поровну между четырьмя детьми. То есть мы количество а - b делим на четыре и получаем количество персиков которое получил каждый из детей.
Пример на продукте - бананы
program v1;
var m,n,sum,t:integer;
st1:string[10];
begin
sum:=0; t:=0;
writeln('Здравствуйте');
writeln('Банан красного цвета стоит 2500, банан синего цвета стоит 3000, банан черного цвета стоит 3700');
writeln('Сколько купите бананов '); readln(n);
writeln('Введите цвет бананов '); readln(st1);
if (st1='Красного') or (st1='красного') or (st1='Красный') or (st1='красный') then sum:=3000*n;
if (st1='Синего') or (st1='синего') or (st1='Синий') or (st1='синий') or (st1='Синей') or (st1='синей') then sum:=2500*n;
if (st1='Черного') or (st1='черного') or (st1='Чёрного') or (st1='чёрного') or (st1='Черный') or (st1='черный') or (st1='чёрный') or (st1='Чёрный') then sum:=3700*n;
writeln('Сумма покупки ', sum);
writeln('Введите сумму'); readln(m);
t:=m-sum;
writeln('Возьмите сдачу ',t);
writeln('Всего доброго, приходите еще');
end.
По условию данной нам задачи сказано, что общее число купленных персиков равно неизвестной а, также после покупки количества а персиков мы убираем от количества а количество b персиков, так как они оказались ещё зелёными. Следовательно у нас имеется количество съедобных персиков равны а - b. По условию задачи дано, что количество съедобных персиков было разделено поровну между четырьмя детьми. То есть мы количество а - b делим на четыре и получаем количество персиков которое получил каждый из детей.
ответ : каждый получил ( а - b ) / 4 персиков