В
Все
Б
Биология
Б
Беларуская мова
У
Українська мова
А
Алгебра
Р
Русский язык
О
ОБЖ
И
История
Ф
Физика
Қ
Қазақ тiлi
О
Окружающий мир
Э
Экономика
Н
Немецкий язык
Х
Химия
П
Право
П
Психология
Д
Другие предметы
Л
Литература
Г
География
Ф
Французский язык
М
Математика
М
Музыка
А
Английский язык
М
МХК
У
Українська література
И
Информатика
О
Обществознание
Г
Геометрия
KILKOlo
KILKOlo
03.10.2020 22:45 •  Информатика

Написать программу,которая определяет в массиве количество чисел кратных 4 и выписывает наибольшее из них

Показать ответ
Ответ:
Lesya2601
Lesya2601
29.08.2022 00:14
1)
program chik;
var a:array[1..100]of integer;
i,s:integer;
begin
for i:=1 to 11 do
begin
read(a[i]);
end;
s:=0;
for i:=1 to 11 do
begin
if(a[i] mod 5=0)then s:=s+a[i];
end;
write(s);
end.
 2)
program chik2;
var a:array[1..100]of integer;
i,s:integer;
begin
s:=0;
for i:=1 to 11 do
begin
read(a[i]);
end;
s:=0;
for i:=1 to 11 do
begin
if(a[i] mod 2=1)then s:=s+1];
end;
write(s);
end.
3)
program chik3;
var a:array[1..1000]of integer;
i:integer;
begin
for i:=1 to 9 do
begin
read(a[i]);
end;
for i:=1 to 9 do
begin
if(a[i] mod 2=0)then write(a[i],' ');
end;
end. 
0,0(0 оценок)
Ответ:
Danielriisna13
Danielriisna13
21.06.2021 19:01
В египетских иероглифах видимые предметы обозначались соответствующими изображениями (рука, рот, палец, и так далее) или символичными знаками (солнце, месяц, царь и так далее). Для глаголов употребляли изображение близких символов: скипетр – господствовать, две ноги – ходить, слизняк, что оставляет черепашку, – выходить и так далее. Если не учитывать некоторые «святые» книги, то можно утверждать, что на папирусах не применялось первичное иероглифическое письмо, с его численными образами; употреблялась более удобная скорописная форма иероглифического письма, так называемое иератическое. Название походит с греческого «священный». Ввел это название также Климент Александрийский. Это священное письмо жрецов развилось приблизительно в III тысячелетии до н.э. и имело составной характер. Возникновение иератического письма связывают с применением папируса как материала для письма. Сначала переписчики копировали формы иероглифов, высеченных на камнях, а со временем стали сокращать и совершенствовать некоторые знаки. Так и выработалась иератическое письмо, которое, хотя и походит от первобытного египетского, по качеству, однако, есть уже новым. Следует заметить, что название этого вида письма «священным» является условным, так как сфера его воздействия была намного шире и охватывала все стороны общественной жизни. С изобретением папируса изменяется не только внешняя форма иероглифов, но и их содержание. Постепенно значение иероглифов как идеографического письма – обозначение понятий, вещей (в некоторых случаях) – заменяется хотя и примитивным, но фонетическим письмом. Для этого египтяне составили алфавит, но в нем совсем не было гласных. Рассказывая с такого письма про окружающие события и вещи, египтяне, однако, столкнулись с трудностями при написании собственных имен. 
Написать слово, напоминающее какую-то вещь, было просто, но когда оно не ассоциировалось с вещью, дело усложнялось. Тогда, плюс к сотне известных иероглифов, означавших слова, египтяне придумали еще 24 настоящих буквы. Система их создания была очень простой. В египетском языке было очень много коротких слов, например «пуи» - одеяло, «ро» - рот. Согласно новым правилам, рисунок рта также обозначал букву «р». К слову, написанному буквами, египтяне часто прибавляли детерминатив, отображающий написанное. Так, писали «ан» - рыба и сопровождали написанное рисунком. Делалось это не только потому, что читатели не привыкли к письму с буквами, но еще и потому, что много слов писалось одинаково. Без этих своеобразных «ключей» в египетском письме была бы большая путаница. Если бы мы теперь не знали гласных, то нам бы пришлось придумывать много ключей для правильного чтения слов, написанных без них. 
На каменных стенах египетских храмов и в папирусных сувоях уживаются рядом иероглифы разных значений. Тут и знаки, что отображают целые слова или обозначающие слоги, и настоящие буквы. 
Позднее, в VII ст. до н.э в северном Египте пробилась другая скорописная форма египетского письма – демотическое (термин ввел Геродот). Ранние образцы этого письма наблюдались в светских памятках еще в X ст. до н.э. С VI ст. до н.э. оно преобразовывается в азбучно-фонетическое, но без гласных букв. Демотическое письмо было проще и легче для быстрого письма. 
Когда Египет утратил свою независимость, египетское письмо, язык и культура быстро пришли в упадок, попав под греческое и латинское влияние. В III ст. до н.э греческий язык и письмо одерживают окончательную победу. Египтяне начали использовать письмо, базирующееся на греческом алфавите, которое называли коптским.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота