В
Все
Б
Биология
Б
Беларуская мова
У
Українська мова
А
Алгебра
Р
Русский язык
О
ОБЖ
И
История
Ф
Физика
Қ
Қазақ тiлi
О
Окружающий мир
Э
Экономика
Н
Немецкий язык
Х
Химия
П
Право
П
Психология
Д
Другие предметы
Л
Литература
Г
География
Ф
Французский язык
М
Математика
М
Музыка
А
Английский язык
М
МХК
У
Українська література
И
Информатика
О
Обществознание
Г
Геометрия
nickartyar
nickartyar
01.10.2020 17:45 •  Информатика

Написать программу, которая определяет, попадет ли точка с заданными координатами в область, закрашенную на рисунку серым цветом. Результат работы программы вывести в виде текстового сообщения.( На языке C#)

Показать ответ
Ответ:
vadimkvitko20
vadimkvitko20
20.05.2021 15:50

1)var

a:array[1..5]of integer;

i,n,s:integer;

begin

 writeln('Введите кол-во элементов');

 readln(n);

 writeln('Введите число');

 s:=0;

 for i:=1 to n do begin

   read(a[i]);

   if a[i]>0 then s:=s+a[i]

 end;

 writeln('Сумма положительных элементов массива равна ', s)

end.

2)var

a:array[1..10]of integer;

i,n,P:integer;

begin

 writeln('Введите число элементов');

 readln(n);

 writeln('Введите число');

 P:=1;

 for i:=1 to n do begin

   read(a[i]);

   if a[i] mod 6 = 0  

   then P:=P*a[i]

 end;

 writeln('Произведение элементов массива кратных 6 равна ',P)

end.

3)var

a:array[1..5]of integer;

n,i:integer;

begin

 writeln('Введите кол-во элементов');

 readln(n);

 writeln('Введите число');

 for i:=1 to n do begin

   read(a[i]);

   if a[i]>0 then begin

   a[i]:=a[i]*3;

   writeln('Новый элемент равен: ',a[i])

 end;

 if a[i]<=0 then begin

   a[i]:=a[i]+5;

    writeln('Новый элемент равен: ',a[i])

 end;

 end;

end.

Буду рад если отметишь мой ответ как лучший

0,0(0 оценок)
Ответ:
angelikasolnce1
angelikasolnce1
08.06.2020 17:14

Машинная память работает по принципу 0 и 1, т. е. 0 это нету сигнала, 1 это есть сигнал. По этому для понимания мы может просто записывать это в таблицу.

К примеру возьмём 2 клетки. Если и первая клетка и вторая равна 1, тогда выполняется что то одно, если не равны, то что то другое.

На самом компьютере да и вообще любом современном электронном устройстве всё работает по этому же принципу, только вместо таблицы с 0 и 1, используется "Есть питания" или же "Нету питания", поступил ток по нужному проводу или нет.

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота