В
Все
Б
Биология
Б
Беларуская мова
У
Українська мова
А
Алгебра
Р
Русский язык
О
ОБЖ
И
История
Ф
Физика
Қ
Қазақ тiлi
О
Окружающий мир
Э
Экономика
Н
Немецкий язык
Х
Химия
П
Право
П
Психология
Д
Другие предметы
Л
Литература
Г
География
Ф
Французский язык
М
Математика
М
Музыка
А
Английский язык
М
МХК
У
Українська література
И
Информатика
О
Обществознание
Г
Геометрия
Duma10
Duma10
02.02.2022 22:40 •  Информатика

Написать программу, которая определяет, каким днем (рабочий день, суббота, воскресенье) является введенный номер дня недели. в теранарном операторе, как делать?

Показать ответ
Ответ:
irishkakrasa
irishkakrasa
07.10.2020 11:42
Не "теранарный", а тернарный оператор.
Есть во многих языках программирования, зря не указали, какой Вам надо.

// PascalABC.NET 3.3, сборка 1590 от 03.12.2017
// Внимание! Если программа не работает, обновите версию!

begin
  var n:=ReadInteger('День недели (1- Пн, 2- Вт, ... 7- Вс:');
  Writeln(n<6?'Рабочий день':n=6?'Суббота':'Воскресенье')
end.

Примеры (предполагается без проверки корректность ввода)
День недели (1- Пн, 2- Вт, ... 7- Вс: 4
Рабочий день

День недели (1- Пн, 2- Вт, ... 7- Вс: 6
Суббота

День недели (1- Пн, 2- Вт, ... 7- Вс: 7
Воскресенье
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота