Войти
Регистрация
Спроси ai-bota
В
Все
Б
Биология
Б
Беларуская мова
У
Українська мова
А
Алгебра
Р
Русский язык
О
ОБЖ
И
История
Ф
Физика
Қ
Қазақ тiлi
О
Окружающий мир
Э
Экономика
Н
Немецкий язык
Х
Химия
П
Право
П
Психология
Д
Другие предметы
Л
Литература
Г
География
Ф
Французский язык
М
Математика
М
Музыка
А
Английский язык
М
МХК
У
Українська література
И
Информатика
О
Обществознание
Г
Геометрия
Показать больше
Показать меньше
darkbluefox
02.12.2022 02:40 •
Информатика
Написать программу,которая находит все четырехзначные числа abcd,для которых выполняются условия 1)a,b,c,d-разные цифры 2)a*b-c*d=a+b+c+d
Показать ответ
Ответ:
moȗnuk
03.07.2020 22:34
Program fofgogjoj;
var
a,b,c,d:integer;
begin
for c:=0 to 7 do
begin
a:=c+2;
d:=9-c;
for b:=0 to 9 do
begin
if (b<>c)and(b<>a)and(b<>d) then
Writeln(a,b,c,d);
Writeln;
end;
end;
readln;
end.
0,0
(0 оценок)
Популярные вопросы: Информатика
Девчуля08
28.05.2023 14:58
1. Составьте алгоритм вычисления данного выражения (см. варианты 1-е вложение). 2. Нарисуйте блок-схему алгоритма. 3. Напишите программу. Пример: Образец выполнения задания...
Runet13
03.04.2023 22:43
Составьте программму так чтобы из слово информатика вышло обратное слово акриарофниИ. Сделайте...
анастейша1410
10.06.2021 21:25
3. Обчисліть довжину двійкового коду деякого тексту за умови, що символи тексту закодовані з використанням таблиці кодів символівWindows-1251. У тексті 32 сторінки, кожна...
yaooiojhh
12.06.2022 14:18
Техника безопасности с утюгом...
Neymar3110
28.02.2020 23:50
Перевести 213 35432 перевести в двоичную и восьмиричную систему 432 перевести в восьмиричную в 16 -ную систему...
voronvoron2002
05.06.2022 01:59
В одній множині 90 елемент(ів/а), а у іншій — 19. Яка максимальна кількість елементів може бути в їх перетині?...
ilya494
26.06.2020 04:54
Биология. 6 класс. Тема: «Размножение растений » Вариант 1.Чассть А. Выберите один правильный ответ.Размножение одноклеточных водорослей происходит:а) бесполым путём б)...
naoimiiwsvb2
19.09.2021 06:37
Сегодня была видна полная Луна. Нарисуйте, как она будет выглядеть в это время....
riabinova19
13.05.2022 02:04
Является ли интернет средством массовой информации? мне нужно эссе по этой теме, то есть минусы и плюсы , ну и вообще сочинение СВОИМИ СЛОВАМИ...
ilyajdbda
22.04.2022 01:12
Mg-- MgO-- Mg(NO3)2-- Mg(OH)2...
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota
Оформи подписку
О НАС
О нас
Блог
Карьера
Условия пользования
Авторское право
Политика конфиденциальности
Политика использования файлов cookie
Предпочтения cookie-файлов
СООБЩЕСТВО
Сообщество
Для школ
Родителям
Кодекс чести
Правила сообщества
Insights
Стань помощником
ПОМОЩЬ
Зарегистрируйся
Центр помощи
Центр безопасности
Договор о конфиденциальности полученной информации
App
Начни делиться знаниями
Вход
Регистрация
Что ты хочешь узнать?
Спроси ai-бота
var
a,b,c,d:integer;
begin
for c:=0 to 7 do
begin
a:=c+2;
d:=9-c;
for b:=0 to 9 do
begin
if (b<>c)and(b<>a)and(b<>d) then
Writeln(a,b,c,d);
Writeln;
end;
end;
readln;
end.