Войти
Регистрация
Спроси ai-bota
В
Все
Б
Биология
Б
Беларуская мова
У
Українська мова
А
Алгебра
Р
Русский язык
О
ОБЖ
И
История
Ф
Физика
Қ
Қазақ тiлi
О
Окружающий мир
Э
Экономика
Н
Немецкий язык
Х
Химия
П
Право
П
Психология
Д
Другие предметы
Л
Литература
Г
География
Ф
Французский язык
М
Математика
М
Музыка
А
Английский язык
М
МХК
У
Українська література
И
Информатика
О
Обществознание
Г
Геометрия
Показать больше
Показать меньше
SashaV2003
20.02.2022 13:59 •
Информатика
Написать программу, которая находит сумму элементов массива кратных 3.
Показать ответ
Ответ:
ytytuty
23.09.2020 16:25
Const n = 10;
var a:array[0..10] of integer;
i,s:integer;
begin
for i := 1 to n do begin
a[i]:=random(21)-10;
write(a[i]:4);
end;
writeln;
for i := 1 to n do
if a[i] mod 3 = 0 then s := s + a[i];
writeln('Сумма кратных трем ',s);
end.
Тестовое решение:
8 -4 8 10 2 1 -7 9 2 0
Сумма кратных трем 9
0,0
(0 оценок)
Популярные вопросы: Информатика
0Peppa0
15.05.2020 23:19
1) Діалогова система обробки даних, поданих у виглядіпрямокутної таблиці називається …2) Електронні таблиці зручні тим, що дані в них розміщуються увигляді …..3) Кожна...
leralerochka202
08.02.2021 22:16
4. выполните шаги для открытия панели «форматирование ячеек»: 1.. 2. 3. …...
guzel32211
25.11.2020 03:12
Запишите в тетрадях основные термины , о которых вы узнали. информатика 5 класс стр . 51 номер 4 !...
pikapchu
10.01.2022 22:51
Ввести номер месяца и номер дня, вывести число дней, оставшихся до нового года. пример: введите номер месяца 12 введите день 25 до нового года осталось 6 дней. p.s.:...
Sasha808621
07.04.2023 00:23
Сколько значащих нулей в двоичной записи шестнадцатеричного числа 18dc,c816? ноль называется значащим, если удаление его из записи числа ведёт к изменению значения...
elkaE
07.04.2023 00:23
Составить программу нахождения суммы элементов массива, состоящую из 10 чисел. язык pascal...
mariazeleznak2
16.04.2022 13:57
Ввести номер месяца и номер дня, вывести число дней, оставшихся до нового года. пример: введите номер месяца 12 введите день 25 до нового года осталось 6 дней....
SonyaKot1
10.08.2022 13:55
Имеется последовательность чисел 0, 5, 50, 55, 500, 505, 550, 555, 5000, 5005, 5050 и так далее (числа состоят только из 0 и 5, числа записаны в порядке возрастания)....
екатерина699
03.11.2020 09:35
Напишите программу, которая вычисляет факториал натурального числа n ( 1 ≤ n ≤ 10000 ), сохранив все значащие цифры. факториалом называется произведение всех натуральных...
Qween123452003
01.04.2021 06:15
Написать программу в паскале y=2*x^2+b...
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota
Оформи подписку
О НАС
О нас
Блог
Карьера
Условия пользования
Авторское право
Политика конфиденциальности
Политика использования файлов cookie
Предпочтения cookie-файлов
СООБЩЕСТВО
Сообщество
Для школ
Родителям
Кодекс чести
Правила сообщества
Insights
Стань помощником
ПОМОЩЬ
Зарегистрируйся
Центр помощи
Центр безопасности
Договор о конфиденциальности полученной информации
App
Начни делиться знаниями
Вход
Регистрация
Что ты хочешь узнать?
Спроси ai-бота
var a:array[0..10] of integer;
i,s:integer;
begin
for i := 1 to n do begin
a[i]:=random(21)-10;
write(a[i]:4);
end;
writeln;
for i := 1 to n do
if a[i] mod 3 = 0 then s := s + a[i];
writeln('Сумма кратных трем ',s);
end.
Тестовое решение:
8 -4 8 10 2 1 -7 9 2 0
Сумма кратных трем 9