В
Все
Б
Биология
Б
Беларуская мова
У
Українська мова
А
Алгебра
Р
Русский язык
О
ОБЖ
И
История
Ф
Физика
Қ
Қазақ тiлi
О
Окружающий мир
Э
Экономика
Н
Немецкий язык
Х
Химия
П
Право
П
Психология
Д
Другие предметы
Л
Литература
Г
География
Ф
Французский язык
М
Математика
М
Музыка
А
Английский язык
М
МХК
У
Українська література
И
Информатика
О
Обществознание
Г
Геометрия
kate807
kate807
10.10.2020 21:59 •  Информатика

Написать программу ,которая на вход получает число p.на входе определяет колличество его четных и нечетных делителей c++

Показать ответ
Ответ:
Региша10
Региша10
13.07.2020 06:11
#include <iostream> 
int main() {
  int x, c=0, odd=0;
  std::cin >> x;

  for (int i = 1; i<=x; i++) 
    if (!(x%i)) {
      c++;
      if(i%2)
        odd++; 
    }
  std::cout << c - odd << " HE: " << odd << std::endl;
    
  return 0; 
}
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота