В
Все
Б
Биология
Б
Беларуская мова
У
Українська мова
А
Алгебра
Р
Русский язык
О
ОБЖ
И
История
Ф
Физика
Қ
Қазақ тiлi
О
Окружающий мир
Э
Экономика
Н
Немецкий язык
Х
Химия
П
Право
П
Психология
Д
Другие предметы
Л
Литература
Г
География
Ф
Французский язык
М
Математика
М
Музыка
А
Английский язык
М
МХК
У
Українська література
И
Информатика
О
Обществознание
Г
Геометрия
alinka660066
alinka660066
26.10.2021 22:02 •  Информатика

Написать программу, которая из случайно сформированного
одномерного массива размерности 10 выводит только те
элементы, значения которых принадлежат отрезку [-6; 30].
Для заполнения массива использованы случайные числа от -
10 до 50.

Показать ответ
Ответ:
iuliazhdanovaЮлька
iuliazhdanovaЮлька
13.10.2020 11:32

Program Rnd2020;

type rnd_array = array [1..10] of integer;

var

  i:1..10;

 k:integer;

a: rnd_array;

v:integer;

begin

       (* инициализируем генератор случайных чисел *)

      randomize;

    for i:=1 to 10 do

    a[i]:=rand(41)+10;

    for i:=1 to 10 do

   begin

            v:=a[i];

            if ((v>=  -6) and (v<=30)) then

              writeln(v);

    end;

end.

Объяснение:

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота