В
Все
Б
Биология
Б
Беларуская мова
У
Українська мова
А
Алгебра
Р
Русский язык
О
ОБЖ
И
История
Ф
Физика
Қ
Қазақ тiлi
О
Окружающий мир
Э
Экономика
Н
Немецкий язык
Х
Химия
П
Право
П
Психология
Д
Другие предметы
Л
Литература
Г
География
Ф
Французский язык
М
Математика
М
Музыка
А
Английский язык
М
МХК
У
Українська література
И
Информатика
О
Обществознание
Г
Геометрия
farkhod88
farkhod88
25.07.2021 05:22 •  Информатика

Написать программу, которая генерирует и выводит на экран массив из 10 случайных чисел в диапазоне от -100 до 100, меняет местами первую и вторую половину массива и выводит новый массив на экран.

Показать ответ
Ответ:
cocosobanro
cocosobanro
26.05.2020 17:28

#include <iostream>
using std::cout;
using std::endl;
#include <cstdlib>
using std::rand;
using std::srand;
#include <ctime>
using std::time;

int main()
{
    int a[10];

    srand(time(0));

    for(int i = 0; i < 10; i++)
    {
        a[i] = rand() % 201 - 100;

        cout << a[i] << ' ';
    }
    cout << endl;

    int temp;
    for(int i = 0; i < 5; i++)
    {
        temp = a[i];
        a[i] = a[i + 5];
        a[i + 5] = temp;
    }

    for(int i = 0; i < 10; i++)
    {
        cout << a[i] << ' ';
    }
    cout << endl;

    return 0;
}


Написать программу, которая генерирует и выводит на экран массив из 10 случайных чисел в диапазоне о
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота