В
Все
Б
Биология
Б
Беларуская мова
У
Українська мова
А
Алгебра
Р
Русский язык
О
ОБЖ
И
История
Ф
Физика
Қ
Қазақ тiлi
О
Окружающий мир
Э
Экономика
Н
Немецкий язык
Х
Химия
П
Право
П
Психология
Д
Другие предметы
Л
Литература
Г
География
Ф
Французский язык
М
Математика
М
Музыка
А
Английский язык
М
МХК
У
Українська література
И
Информатика
О
Обществознание
Г
Геометрия
Кэт32131
Кэт32131
17.12.2020 12:47 •  Информатика

Написать программу,которая формирует массив из двадцати случайных чисел и выводит на экран элементы кратные числу 4

Показать ответ
Ответ:
mihailova1999
mihailova1999
23.12.2020 20:29
Берем, например, число 29. Поскольку это число нечетное, отнимаем от него единицу, - записываем ее отдельно, а число делим пополам. Получилось 14. (1)
Число 14 - четное. Отнимать от него единицу не нужно, поэтому слева от "запомненной" единицы запишем 0. Число делим пополам, получаем 7. (0)
Число 7 - опять нечетное. Отнимаем от него 1, записываем отдельно и делим число пополам. Получаем 3. (1)
Число 3 - нечетное. Отнимаем 1, записываем ее отдельно, и результат делим пополам, получаем 1. (1)
Последнюю единицу уже не делим, а просто записываем слева от полученного результата.
Смотрим на результат. У нас получилось двоичное число - это и есть двоичный код числа 29.
0,0(0 оценок)
Ответ:
ванга13
ванга13
17.05.2022 04:42
//Dev-C++ 5.11

#include <iostream>
using namespace std;

int main(void)
 {const int n=6;
 int arr[n],c;
 for(int i=0;i<n;i++)
  cin>>arr[i];
 for(int i=0;i<n-1;i++)
  for(int j=i+1;j<n;j++)
   if(arr[i]>arr[j] && arr[i]%2==0 && arr[j]%2==0)
    {c=arr[i];
    arr[i]=arr[j];
    arr[j]=c;}
 for(int i=0;i<n-1;i++)
  for(int j=i+1;j<n;j++)
   if(arr[i]<arr[j] && arr[i]%2!=0 && arr[j]%2!=0)
    {c=arr[i];
    arr[i]=arr[j];
    arr[j]=c;}
 cout<<"Array"<<endl;
 for(int i=0;i<n;i++)
  cout<<arr[i]<<" ";
 return 0;}

Пример ввода:
2 6 4 1 5 3
Пример вывода:
Array
2 4 6 5 3 1
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота