Написать программу, которая формирует двумерную матрицу чисел размерностью n*n. Затем
формирует два одномерных массива, причем в один записываются элементы, расположенные на
главной диагонали и выше, в другой – элементы матрицы, лежащие ниже главной диагонали и
выводит все массивы на экран. Осуществить бинарный поиск заданного элемента во втором
массиве.
#include <string.h>
#include <algorithm>
using namespace std;
int main() {
int n;
scanf("%d", &n);
bool a[n][n];
memset(a, true, sizeof(a));
int m;
scanf("%d", &m);
for (int k = 0; k < m; ++k) {
int x, y, aa;
scanf("%d%d%d", &x, &y, &aa);
for (int i = x; i < min(x + aa, n + 1); ++i) {
for (int j = y; j < min(y + aa, n + 1); ++j) {
a[i][j] = false;
}
}
}
int cnt = 0;
for (int i = 0; i < n; i++) {
for (int j = 0; j < n; j++) {
if (a[i][j]) {
cnt++;
}
}
}
printf("%d", cnt);
return 0;
}
лазерный же имеет сухой порошок (называемый тоннером), который "прижаривается" к бумаге лучом лазера (лазер нагревает краску, заставляя ее прилипать к бумаге). Свойств у лазерных мало, основное это разрешение печати (насколько мелкой может быть одна точка).
А если речь идет о их общих свойствах: то наверное можно отметить такие - разрешение печати, цветность, размер (форматы бумаги), типы используемой бумаги, односторонний\двухсторонний, сетевой\локальный и другие (их довольно много)