В
Все
Б
Биология
Б
Беларуская мова
У
Українська мова
А
Алгебра
Р
Русский язык
О
ОБЖ
И
История
Ф
Физика
Қ
Қазақ тiлi
О
Окружающий мир
Э
Экономика
Н
Немецкий язык
Х
Химия
П
Право
П
Психология
Д
Другие предметы
Л
Литература
Г
География
Ф
Французский язык
М
Математика
М
Музыка
А
Английский язык
М
МХК
У
Українська література
И
Информатика
О
Обществознание
Г
Геометрия
gorodchikova23
gorodchikova23
20.07.2022 03:36 •  Информатика

Написать программу, которая бы по введенному номеру единицы измерения (1-дециметр, 2-километр, 3-метр, 4-миллиметр, 5-сантиметр) и длине отрезка l выдавала соответствующее значение длины отрезка в метрах. паскаль, использовать оператор условие if

Показать ответ
Ответ:
gryzzly12
gryzzly12
07.10.2020 10:55
//Pascal
var
  Ez: byte;
  z: real;
begin
  writeln('1 - дециметр, 2 - километр, 3 - метр, 4 - миллиметр, 5 - сантиметр');
  write('Введите номер единицы измерения: '); readln(Ez);
  write('Введите длинну: '); readln(z);
  if Ez = 1 then writeln(z/10, ' м');
  if Ez = 2 then writeln(z*1000, ' м');
  if Ez = 3 then writeln(z, ' м');
  if Ez = 4 then writeln(z/1000, ' м');
  if Ez = 5 then writeln(z/100, ' м');
  readln; 
end.  

Написать программу, которая бы по введенному номеру единицы измерения (1-дециметр, 2-километр, 3-мет
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота