Написать программу,Котора вычисляет расстояние между двумя точками на плоскости с заданными координатами (X1,Y1),(X2,Y2)
Подсказка формула для нахождения расстояния между двумя точками выглядит так d=Корень из ( X2,-X1)-в квадрате + (Y2-Y1)-в квадрате
Решение на c++:
#include <iostream>
#include <ctime>
int main()
{
int N, i, a, b, k1 = 0, k2 = 0, s1 = 0, s2 = 0;
int A[10000];
std::cin >> a >> b >> N;
srand(time(0));
for (i = 0; i < N; i++)
{
A[i] = rand()%(b-a+1)+a;
if (A[i] < 50)
{
k1++;
s1 += A[i];
}
else
{
k2++;
s2 += A[i];
}
std::cout << A[i] << " ";
}
std::cout << std::endl << ((k1 == 0) ? 0 : (s1*1./k1)) << " ";
std::cout << ((k2 == 0) ? 0 : (s2 * 1. / k2)) << " ";
return 0;
}
1) Переведем размер изображения из сантиметров в дюймы. Исходя из того, что 1 дюйм = 2,54 см., получаем: 30.48 см = 30.48 / 2.54 = 12 дюймов.
2) Размер изображения в дюймах равен: 12 * 12 = 144 дюйма.
3) Информационный объем графического файла определяется по формуле: l = K * i, где к - общее количество точек изображения, i - глубина цвета.
К = 600 * 1200 * 144 = 103680000 (умножили разрешение сканера на размер изображения).
l = 103680000 * 8 бит = 829440000 бит.
Переведем в мегабайты: 829440000 бит = 829440000 / 8 = 103680000 байт.
103680000 байт = 103680000 / 1024 = 101250 килобайт.
101250 килобайт = 101250 / 1024 = 98,88 мегабайт.
ответ: 98,88 мегабайт.
Объяснение: