В
Все
Б
Биология
Б
Беларуская мова
У
Українська мова
А
Алгебра
Р
Русский язык
О
ОБЖ
И
История
Ф
Физика
Қ
Қазақ тiлi
О
Окружающий мир
Э
Экономика
Н
Немецкий язык
Х
Химия
П
Право
П
Психология
Д
Другие предметы
Л
Литература
Г
География
Ф
Французский язык
М
Математика
М
Музыка
А
Английский язык
М
МХК
У
Українська література
И
Информатика
О
Обществознание
Г
Геометрия
Араиприпо
Араиприпо
09.08.2022 06:55 •  Информатика

Написать программу котора, проверяет делится ли на пять введенное с клавиатуры письмонаписать программу которая выводит таблицу квадратов первых десяти целых положительных чисел​

Показать ответ
Ответ:
daryanashpakov
daryanashpakov
05.12.2022 05:36

program Lyonyshna;
const
    Rus = ['А'..'Я', 'а'..'я'];
    Lat = ['A',..'Z', 'a'..'z'];
Var f,frus,flat,foth:text;
    i: integer;
    st,strus,stlat,stoth: string;
begin
    Assign(f, 'file1.txt');
    Rewrite(f);
    write('Введите исходную строку: '); readln(st);
    writeln(f,st);
    close(f);
    strus:='';
    stlat:='';
    stoth:='';
    Reset(f);
    Assign(frus, 'russian.txt');
    Rewrite(frus);
    Assign(flat, 'latin.txt');
    Rewrite(flat);
    Assign(foth, 'other.txt');
    Rewrite(foth);
    Readln(f,st);
    for i:=1 to length(st) do
      if st[i] in rus then strus:=strus+st[i]
        else
          if st[i] in lat then stlat:=stlat+st[i]
            else
              stoth:=stoth+st[i];
    Writeln(frus,strus);
    Writeln(flat,stlat);
    Writeln(foth,stoth);
    Writeln('Русские символы: ',strus);
    Writeln('Латинские символы: ',stlat);
    Writeln('Другие символы: ',stoth);
    Close(f); Close(frus); Close(flat);  Close(foth);
end.

0,0(0 оценок)
Ответ:
Kate0526
Kate0526
05.06.2020 12:48

Правильность не гарантирую, потому что проверить в данный момент код негде.

 

Sub название

Dim A() As Integer
Dim b() As Integer
Dim i, j As Integer

 

'Задаем размерность массива
Console.WriteLine ("Введите количество строк")
n = Console.ReadLine                                             
Console.WriteLine ("Введите количество столбцов")
m = Console.ReadLine


ReDim A(n, m) As Integer
ReDim b(n) As Integer

 

'Цикл ввода данных
For i = 1 To n
For j = 1 To m
Console.WriteLine ("Введите число")
A(i, j) = Console.ReadLine
Next j
Next i

 

'Все элементы массива b изначально делаем единичными, чтобы при умножении они не повлияли на значение
For i = 1 To n
b(i) = 1
Next i

 

'Цикл вычисления каждого элемента массива b
For i = 1 To n
For j = 1 To m
b(i) = b(i) * A(i, j)
Next j
Next i

 

'Вывод результата на экран
For i = 1 To n
Console.Write (b(i))
Next i
End Sub

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота