В
Все
Б
Биология
Б
Беларуская мова
У
Українська мова
А
Алгебра
Р
Русский язык
О
ОБЖ
И
История
Ф
Физика
Қ
Қазақ тiлi
О
Окружающий мир
Э
Экономика
Н
Немецкий язык
Х
Химия
П
Право
П
Психология
Д
Другие предметы
Л
Литература
Г
География
Ф
Французский язык
М
Математика
М
Музыка
А
Английский язык
М
МХК
У
Українська література
И
Информатика
О
Обществознание
Г
Геометрия
santchkaakimowa
santchkaakimowa
03.04.2023 19:36 •  Информатика

Написать программу,каторая выделит все запятые из строки st начиная с позиции р

Показать ответ
Ответ:
Juliana2414
Juliana2414
30.09.2020 14:26

 {Программа на Free Pascal}

Var st:string;

z,p,i:integer;

begin

z:=0;

readln(st);{Считываем строку}

read(p);{Считываем позию}

for i:=p to length(st) do if(st[i] = ',') then inc(z);{Пробегаемся по строке с позиции p и ищем ,}

writeln(z);{Выводим кол-во найденых запятых}

end.

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота