Написать программу, использующую ПРОЦЕДУРУ ФУНКЦИЮ для определения объема параллелепипеда (длину, высоту и ширину вводит пользователь). Ввод и вывод данных осуществляется в теле основной программы.
В двух скриншотах исходный код в редакторе и результат выполнения программы. В качестве объяснения скажу, что мы объявили функцию volume которая считает объем по переданным в нее измерениям параллелепипеда и возвращает значение. В основной части программы мы вводим измерения и передаем их в функцию, потом выводим результат. Переменная v для хранения результата функции.
Исходный код:
program par;
var v, a, b, c: integer;
function volume (a, b, c: integer): integer;
begin
volume := a * b * c
end;
begin
Readln(a);
Readln(b);
Readln(c);
v := volume(a, b, c);
Writeln(v);
end.
Примечание:
В двух скриншотах исходный код в редакторе и результат выполнения программы. В качестве объяснения скажу, что мы объявили функцию volume которая считает объем по переданным в нее измерениям параллелепипеда и возвращает значение. В основной части программы мы вводим измерения и передаем их в функцию, потом выводим результат. Переменная v для хранения результата функции.