В
Все
Б
Биология
Б
Беларуская мова
У
Українська мова
А
Алгебра
Р
Русский язык
О
ОБЖ
И
История
Ф
Физика
Қ
Қазақ тiлi
О
Окружающий мир
Э
Экономика
Н
Немецкий язык
Х
Химия
П
Право
П
Психология
Д
Другие предметы
Л
Литература
Г
География
Ф
Французский язык
М
Математика
М
Музыка
А
Английский язык
М
МХК
У
Українська література
И
Информатика
О
Обществознание
Г
Геометрия
Vasya1godik
Vasya1godik
07.08.2022 21:40 •  Информатика

Написать программу, используя одномерные массивы: Даны натуральное число n, действительные числа x(1), y(1), x(2), y(2),..., x(n), y(n). Известно, что точки p(1), p(2), ..., p(n) с координатами (x(1), y(1)), (x(2), y(2)), ..., (x(n), y(n)) попарно различны. Пусть точка p(i) удалена от начала координат на расстояние r(i) (i=1, ...,n). Пусть R=max(r(1), ...,r(n)). Среди точек p(1), p(2), ..., p(n) выбрать какую-нибудь одну p(i), для которой r(i)=R; указать координаты выбранной точки и расстояние от этой точки до начала координат.

Показать ответ
Ответ:
angelinochka345
angelinochka345
05.08.2020 01:56

//PascalABC.NET версия 3.2, сборка 1389

//Если программа не запускается, то обновите версию

uses System.Linq;

begin

   writeln('III');

   var a := ReadArrInteger('Документы', ReadInteger('n=')).ToList;

   writeln;

   

   while a.Any() do

   begin

       write(a[0], ' ');

       a.RemoveAt(0);

       if not a.Any then break;

       

       write(a.Last, ' ');

       a.RemoveAt(a.Count - 1);

       if not a.Any then break;

       

       var n := 0;

       if a.Count > 1 then n := a.Count div 2 - 1;

       write(a[n], ' ');

       a.RemoveAt(n);

   end;

end.

Объяснение:

0,0(0 оценок)
Ответ:
kazekb
kazekb
26.11.2020 10:53

функция input предназначена для того, чтобы ты из консоли мог давать значение переменной после запуска своей проги. Если ты хочешь, чтобы твоя прога сама предлага вводить параметры а, b, c то стери что в скобке input или напиши так:

a=int(input('a = '))

b=int(input('b = '))

c=int(input('c = '))

и уже как запустишь свою прогу в консоли надо дописать, чему будет равны а, b, c. Или в своей проге укажи чему равны параметры а, b, c. Например:

a=1

b=2

c=3

если тебе нужны только целые числа, округленные в наименьшое целое чилсо, то используй функцию int. Например

a=int(5.9)

print(a)

будет напечатано 5

Объяснение:

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота