В
Все
Б
Биология
Б
Беларуская мова
У
Українська мова
А
Алгебра
Р
Русский язык
О
ОБЖ
И
История
Ф
Физика
Қ
Қазақ тiлi
О
Окружающий мир
Э
Экономика
Н
Немецкий язык
Х
Химия
П
Право
П
Психология
Д
Другие предметы
Л
Литература
Г
География
Ф
Французский язык
М
Математика
М
Музыка
А
Английский язык
М
МХК
У
Українська література
И
Информатика
О
Обществознание
Г
Геометрия
KaterinaReyn
KaterinaReyn
13.03.2020 05:30 •  Информатика

Написать программу, используя линейную структуру.

С клавиатуры вводится любое целое число. Написать программу, которая вычисляет его квадрат.​

Показать ответ
Ответ:
milanaberezova
milanaberezova
19.01.2022 23:44
1. Частота дискретизации определяет количество отсчетов (т.е. измерений) сигнала, которое делается за одну секунду. Частота 8 кГц = 8000 Гц говорит нам о том, что таких отсчетов делается в секунду 8000.
2. Глубина кодирования сообщает о том, на сколько уровней громкости делится каждый звуковой сигнал. 16 бит позволяют иметь два в шестнадцатой степени уровней.
3. Тогда для сохранения информации нам потребуется 8000 х 16 = 128 000 бит.
4. Файл, с длительностью звучания в одну минуту потребует для сохранения данных в 60 раз больше времени (в минуте 60 секунд) или 128 000 х 60 бит.
5. В одном килобайте 1024 байт, а в одном байте 8 бит. Поэтому найденный объем файла надо разделить на 1024 х 8 = 8192. Получим 128000х60/8192=937.5 Кбайт
6. Поскольку файл монофонический, то используется один канал звука и ответом будет вычисленное значение 937.5 Кбайт. В противном случае найденное значение надо умножить на число звуковых каналов.
0,0(0 оценок)
Ответ:
ak9512
ak9512
23.07.2022 07:21
var
s,s1:string;   
a:array[1..100] of string;   
 n,i,j,k:byte;
begin
writeln('Введите текст из слов, разделенных пробелами');
readln(s);
s:=' '+s+' ';
n:=length(s);
i:=2;k:=0;while i<=n do
if (s[i]<>' ')and (s[i-1]=' ') then
begin  k:=k+1;
  j:=i; 
s1:=''; 
 while (j<=n) and (s[j]<>' ') do
   begin 
  s1:=s1+s[j]; 
  j:=j+1;   
end; 
a[k]:=s1;
 i:=i+length(s1);
 end
else i:=i+1;
for i:=1 to k-1 do
for j:=i+1 to k do
if a[i]>a[j] then 
begin  s1:=a[i]; 
 a[i]:=a[j];
  a[j]:=s1
 end;
writeln('Слова текста в алфавитном порядке:');
for i:=1 to k do
writeln(a[i]);
end.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота