Написать программу или хотя бы что нужно делать.Вникнуть никак не могу На Солнечном острове живут w белых и b чёрных хамелеонов. Хамелеоны – это животные,
менять свой цвет. При встрече оба хамелеона меняют свой цвет на противоположный.
Например, при встрече двух белых (или чёрных) хамелеонов оба становятся чёрными (белыми), а
при встрече хамелеонов белого и чёрного цвета они превращаются в хамелеонов чёрного и белого
цвета. В остальных случаях ничего не происходит.
Вам необходимо определить, смогут ли все хамелеоны окраситься в один цвет
#include <cmath>
using namespace std;
void main()
{
int n,sum=0;
float y,k=0;
cin >> n;
int *mass = new int[n];
for (int i = 0;i < n;++i)
{
cin >> mass[i];
}
for (int i = 0;i < n;++i)
{
if (mass[i] >0 )
{
k++;
y=pow(mass[i],2);
cout<<y;
sum+=mas[i]
}
}
system("pause");
}
2)#include <iostream>
#include <cmath>
using namespace std;
void main()
{
int s,p,r,day=0;
cin >> s>>p>>r;
float km=s;
while(r>km)
{
km+=km*p/100;
day++;
}
cout << " km = " << km << " day = " << day << endl;
system ("pause");
}
#include <iostream>
using namespace std;
int k=2;
bool StrangeSeq(int n){
if (k<n){
if(n%k==0){
cout<<"false";
return false;
}
k++;
StrangeSeq(n);
}
else
{
cout<<"true";
return true;
}
}
int main(){
int n;
cin>>n;
StrangeSeq(n);
cin.get();
cin.get();
}