В
Все
Б
Биология
Б
Беларуская мова
У
Українська мова
А
Алгебра
Р
Русский язык
О
ОБЖ
И
История
Ф
Физика
Қ
Қазақ тiлi
О
Окружающий мир
Э
Экономика
Н
Немецкий язык
Х
Химия
П
Право
П
Психология
Д
Другие предметы
Л
Литература
Г
География
Ф
Французский язык
М
Математика
М
Музыка
А
Английский язык
М
МХК
У
Українська література
И
Информатика
О
Обществознание
Г
Геометрия

Написать программу и начертить блок-схемы решения задач:
Дан массив вещественных чисел, состоящий из 10 элементов. Найти максимальный элемент массива.

Показать ответ
Ответ:
Trinogie
Trinogie
13.10.2020 09:52

попробуй это. Тут еще с нахождением его номера

var a:array[1..100] of real;

    i,imax,n:integer;    

max:real;

begin

write('N= ');

readln(n);

for i:=1 to n do     read(a[i]);

writeln('');

imax:=0;

max:=a[1];

for i:=1 to n do     if a[i]>max then

begin max:=a[i];imax:=i;

end;

writeln('max = ',a[imax],' nomer = ',imax);

readln;

end.

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота