В
Все
Б
Биология
Б
Беларуская мова
У
Українська мова
А
Алгебра
Р
Русский язык
О
ОБЖ
И
История
Ф
Физика
Қ
Қазақ тiлi
О
Окружающий мир
Э
Экономика
Н
Немецкий язык
Х
Химия
П
Право
П
Психология
Д
Другие предметы
Л
Литература
Г
География
Ф
Французский язык
М
Математика
М
Музыка
А
Английский язык
М
МХК
У
Українська література
И
Информатика
О
Обществознание
Г
Геометрия
anastasiya258
anastasiya258
15.08.2022 01:25 •  Информатика

Написать программу и блок схему. вот : даны две точки: а(x1; y1) и b(x2; y2) нужно составить программу определяющую, какая из точек находится ближе к началу координат.

Показать ответ
Ответ:
DoraDreamer
DoraDreamer
19.06.2020 06:10
Var x1,y1,x2,y2,d1,d2:real;
begin
  write ('X1 = ');
  readln (x1);
  write ('Y1 = ');
  readln (y1);
  write ('X2 = ');
  readln (x2);
  write ('Y2 = ');
  readln (y2);
  d1:=sqrt(sqr(x1)+sqr(y1));
  d2:=sqrt(sqr(x2)+sqr(y2));
  if d1<>d2 then write ('К началу координат ближе ');
   if d1>d2 then writeln ('вторая точка') else
    if d2>d1 then writeln ('первая точка') else
      writeln ('Обе точки равноудалены друг от друга');
end.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота