В
Все
Б
Биология
Б
Беларуская мова
У
Українська мова
А
Алгебра
Р
Русский язык
О
ОБЖ
И
История
Ф
Физика
Қ
Қазақ тiлi
О
Окружающий мир
Э
Экономика
Н
Немецкий язык
Х
Химия
П
Право
П
Психология
Д
Другие предметы
Л
Литература
Г
География
Ф
Французский язык
М
Математика
М
Музыка
А
Английский язык
М
МХК
У
Українська література
И
Информатика
О
Обществознание
Г
Геометрия
ksuha0812
ksuha0812
02.04.2021 15:24 •  Информатика

Написать программу генерирующую и выводящую на экран стозначное целое число.определить делится ли данное стозначное число на 3 или 9

Показать ответ
Ответ:
рана7
рана7
25.05.2020 21:54

Program zadacha;

Var x:integer;

Begin

  Randomize;

  x:=random(9999999999999999999999999999999999999999999999999999999999999999999999999999999999999999999999999999)+1000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000;

  If (x mod 3=0) then begin

    If (x mod 9=0) then writeln('Делится на 3 и на 9);

  End;

  If (x mod 3=0) then begin

    If (x mod 9>0) then writeln('Делится только на 3);

  End;

  If (x mod 9=0) then begin

    If(x mod 3>0) then writeln('Делится только на 9);

  End; 

End.

 

 

P.S. Вы уверены, что СТОзначное число?

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота