В
Все
Б
Биология
Б
Беларуская мова
У
Українська мова
А
Алгебра
Р
Русский язык
О
ОБЖ
И
История
Ф
Физика
Қ
Қазақ тiлi
О
Окружающий мир
Э
Экономика
Н
Немецкий язык
Х
Химия
П
Право
П
Психология
Д
Другие предметы
Л
Литература
Г
География
Ф
Французский язык
М
Математика
М
Музыка
А
Английский язык
М
МХК
У
Українська література
И
Информатика
О
Обществознание
Г
Геометрия
Bobskromnaysh12
Bobskromnaysh12
25.07.2020 21:45 •  Информатика

Написать программу для вычисления дискриминанта d квадратного уравнения ax2 + bx + c = 0. разработать тесты проверки правильности работы программы для вариантов, когда d> 0, d=0 и d< 0.

Показать ответ
Ответ:
Zhuravl220
Zhuravl220
12.06.2020 18:46

 Выложу решение полного уровнения.

 

var a,b,c,d:integer; x1,x2:real;
begin
writeln('Введите коэффициенты');
readln(a,b,c);
d:=b*b-4*a*c;
if (d<0) then writeln('Нет решения')
else if (d=0) then
begin
x1:=-b/(2*a);
writeln('x=',x1);
end
else begin
x1:=(-b+sqrt(d))/(2*a);
x2:=(-b-sqrt(d))/(2*a);
writeln('x1= ',x1,'x2=',x2);
end;

readln
end.

 

 

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота