В
Все
Б
Биология
Б
Беларуская мова
У
Українська мова
А
Алгебра
Р
Русский язык
О
ОБЖ
И
История
Ф
Физика
Қ
Қазақ тiлi
О
Окружающий мир
Э
Экономика
Н
Немецкий язык
Х
Химия
П
Право
П
Психология
Д
Другие предметы
Л
Литература
Г
География
Ф
Французский язык
М
Математика
М
Музыка
А
Английский язык
М
МХК
У
Українська література
И
Информатика
О
Обществознание
Г
Геометрия
Собака2609
Собака2609
29.03.2021 05:12 •  Информатика

Написать программу для следующих расчетов. Создать одномерный массив размерностью N (вводится с диалогового окна) состоящий из случайных целых чисел в диапазоне [-15;25]. Вывести массив на лист. Найти минимальное число массива. Если минимум является четным, то в ячейку B1 вывести половину его значения, иначе вывести в ячейку B2 удвоенное значение. (Решите в ).​

Показать ответ
Ответ:
moiznaniya1112
moiznaniya1112
04.03.2023 07:04
//Не люблю "примерно так"
//PascalABC.NET 3.2 сборка 1318

Const
  n=10;

  Var
   m,fm:real;
  mc,fmc,i:integer;
val:array[1..n] of real;
begin
for i:=1 to n do
  begin
    readln(val[i]);
    if val[i]>0 then
       begin
        inc(fmc);
        fm+=val[i];
      end
     else
     if val[i]<0 then
      begin
        inc(mc);
        m+=abs(val[i]);
      end
      else
      begin
        writeln('Funny joke!(no)');
        exit;
      end;
 end;
writeln('Male average=',m/mc);
writeln('Female average=',fm/fmc);
end.
0,0(0 оценок)
Ответ:
sashunyakotova
sashunyakotova
09.05.2023 17:50

Задание полностью

Внимательно прочитай текст:

Все эти животные живут, дышат, едят. Все они дикие животные, все имеют хвосты. Это их общие свойства. У лисы и медведя лапы и когти. Они хищники. У слона и лося – ноги. Они травоядные животные. Лиса тявкает. Медведь рычит. У слона бивни и хобот, а у лося рога и копыта, которых нет ни у лисы, ни у медведя.

Заполни таблицу:

Общие свойства для всех объектов

живут, дышат, едят, дикие животные, имеют хвосты

Общие свойства для пар объектов

лиса+медведь - есть лапы, есть когти, хищники

слон+лось - ноги, травоядные

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота