Написать программу для решения задачи на Паскале. Дана строка, содержащая текст на русском языке: «Успех лидера вынашивается на плечах бегущих по пятам». В тексте необходимо заменить все символы «а» на «А». В отчет включить программный код на Паскале и результат работы программы в виде скриншота.
в) Работы с файлами
2. Производительность работы компьютера (быстрота выполнения операций) зависит от:
(b) Частоты процессоpа (частоту процессора можно примерно соотносить с количеством операций в секунду. Но все определяется не только частотой, но и архитектурой процессора: разные процессоры могут за один такт выполнять разное количество элементарных действий)
3. Принцип записи и считывания информации на жесткий диск основан на:
в) Намагничивании участков дисков (на отражении луча лазера основано действие оптических дисков - CD, DVD и т.д.)
4. Дефрагментация - это:
а) Перезапись данных в кластеры, последовательно идущие друг за другом
5. Выберите правильное описание пути к файлу:
б) C:\Games\Chess\Shess.txt (вообще, могут быть еще и а и в: никто не запрещает называть папки именами с точкой, а современные версии windows уменют распознавать пути как прямым слэшем, так и с обратным).
d,x1,x2:real;
begin;
readln(a);
readln(b);
readln(c);
d:=sqr(b)-4*a*c;
if d<0 then
writeln('Нет корней')
else
if d=0 then
begin;
x1:=-b/(2*a);
writeln(x1);
end
else
begin;
x1:=(-b+sqrt(d))/(2*a);
x2:=(-b-sqrt(d))/(2*a);
writeln(x1);
writeln(x2);
end;
end.
2)var x1,y1,x2,y2:integer;
r1,r2,rr:real;
begin;
readln(x1);
readln(y1);
readln(x2);
readln(y2);
r1:=sqrt(sqr(x1)+sqr(y1));
r2:=sqrt(sqr(x2)+sqr(y2));
if r1>r2 then
begin;
rr:=r1-r2;
write('Расстояние от точки А до начала координат больше, чем расстояние от точки В до начала координат на ',rr,' единиц');
end
else
if r1<r2 then
begin;
rr:=r2-r1;
write('Расстояние от точки B до начала координат больше, чем расстояние от точки A до начала координат на ',rr,' единиц');
end
else
write('Точки A и B равноудалены от начала координат');
end.