В
Все
Б
Биология
Б
Беларуская мова
У
Українська мова
А
Алгебра
Р
Русский язык
О
ОБЖ
И
История
Ф
Физика
Қ
Қазақ тiлi
О
Окружающий мир
Э
Экономика
Н
Немецкий язык
Х
Химия
П
Право
П
Психология
Д
Другие предметы
Л
Литература
Г
География
Ф
Французский язык
М
Математика
М
Музыка
А
Английский язык
М
МХК
У
Українська література
И
Информатика
О
Обществознание
Г
Геометрия
gorodkatya
gorodkatya
18.04.2023 11:48 •  Информатика

Написать программу для решения в стиле турбо паскаля 80-х годов. 1.в массиве храниться информация ло количестве людей, живущих на каждом из 15 этажей дома(на первом этаже - в первом элементе массива,на втором - во втором и т.д.) определить два этажа, на которых проживает меньше всего людей. примечание: решить, не используя два прохода по массиву. 2. в начале массива записаны несколько равных между собой элементов. определить количество таких элементов и вывести все элементы, следующие за последним из них. рассмотреть возможность того, что весь массив заполнен одинаковыми элементами

Показать ответ
Ответ:
МияV
МияV
08.10.2020 04:08
Uses Crt;

const
  n=15;
 
var
  i,m1,m2,t:integer;
  k:array[1..n] of integer;

begin
  ClrScr;
  Writeln('Укажите количество людей на каждом этаже');
  for i:=1 to n do Read(k[i]);
  Writeln;
  { массив получен, решаем задачу }
  m1:=1; m2:=2;
  if k[m2]<k[m1] then begin t:=m1; m1:=m2; m2:=t end;
  for i:=3 to n do
    if k[i]<k[m2] then begin m2:=i; t:=m1; m1:=m2; m2:=t end;
  Writeln('Меньше всего людей на этажах ',m1,' и ',m2);
  ReadKey
end.

**************************************************************************************

uses Crt;

const
  n=10;
  a:array[1..n] of integer=(6,6,6,6,3,5,2,1,0,7);
 
var
  i,j,t:integer;

begin
  ClrScr;
  t:=a[1];
  i:=2;
  while (i<=n) and (a[i]=t) do i:=i+1;
  if i<=n then begin
    Writeln('Одинаковых элементов: ', i-1);
    Write('За ними следуют элементы ');
    for j:=i to n do Write(a[j],' ');
    Writeln
    end
  else Writeln('Весь массив заполнен одинаковыми элементами');
  ReadKey
end.

Написать программу для решения в стиле турбо паскаля 80-х годов. 1.в массиве храниться информация ло
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота