Написать программу для решения : в параллели три 5-х класса. в б классе учится на 5 человек больше, чем в а. найдите, сколько человек учится в д классе, если всего в 5-х классах учится 80 человек.
Const n=5; m=4; var a:array[1..n,1..m] of integer; i,j,k,d,s:integer; begin Randomize; writeln('Оценки:'); for i:=1 to n do begin for j:=1 to m do begin a[i,j]:=random(4)+2; write(a[i,j]:4); end; writeln; end; k:=0; s:=0; for i:=1 to n do begin d:=0; for j:=1 to m do begin if a[i,j]=2 then d:=d+1; s:=s+a[i,j]; end; if d>0 then k:=k+1; end; writeln('Количество неуспевающих = ',k); writeln('Средний группы = ',s/n/m); end.
Пример: Оценки: 5 3 3 5 3 4 2 2 4 5 5 5 2 4 4 2 5 2 3 3 Количество неуспевающих = 3 Средний группы = 3.55
var
a:array[1..n,1..m] of integer;
i,j,k,d,s:integer;
begin
Randomize;
writeln('Оценки:');
for i:=1 to n do
begin
for j:=1 to m do
begin
a[i,j]:=random(4)+2;
write(a[i,j]:4);
end;
writeln;
end;
k:=0; s:=0;
for i:=1 to n do
begin
d:=0;
for j:=1 to m do
begin
if a[i,j]=2 then d:=d+1;
s:=s+a[i,j];
end;
if d>0 then k:=k+1;
end;
writeln('Количество неуспевающих = ',k);
writeln('Средний группы = ',s/n/m);
end.
Пример:
Оценки:
5 3 3 5
3 4 2 2
4 5 5 5
2 4 4 2
5 2 3 3
Количество неуспевающих = 3
Средний группы = 3.55
Информационный объем I = 44100 Гц * 5 * 60 с * 16 бит = 211680000 бит = 26460000 байт = 25839,84375 Кбайт = 25,23422241210938 Мбайт
Задание 2
I = 1,3 Мбайт t = 1 мин Частота дискретизации v = 1,3 * 1024 * 1024 * 8 бит / 60 с / 8 бит = 22719,147 Гц
Задание 3
I = 5.1 Мбайт, t = 2 минуты, v = 22050 Гц Разрядность аудиоадаптера i = 5.1 * 1024 * 1024 * 8 бит / (2 * 60) с / 22050 Гц = 16,1685 бит (округленно 16 бит)
Задание 4
I = 0.01 Гбайт, i = 16 бит, v = 44100 Гц Время t = 0,01 * 1024 * 1024 * 1024 * 8 бит / 16 бит / 44100 Гц = 121 с (округляем до 120 с)