В
Все
Б
Биология
Б
Беларуская мова
У
Українська мова
А
Алгебра
Р
Русский язык
О
ОБЖ
И
История
Ф
Физика
Қ
Қазақ тiлi
О
Окружающий мир
Э
Экономика
Н
Немецкий язык
Х
Химия
П
Право
П
Психология
Д
Другие предметы
Л
Литература
Г
География
Ф
Французский язык
М
Математика
М
Музыка
А
Английский язык
М
МХК
У
Українська література
И
Информатика
О
Обществознание
Г
Геометрия
Ухв
Ухв
31.01.2023 07:55 •  Информатика

Написать программу для решения уравнения ax2+ bx+c=0. (дописать до конца) 2)написать программу для решения неравенства bx+c< 0. 3)написать программу для решения уравнения + = 0

Показать ответ
Ответ:
sfsv4641de2r
sfsv4641de2r
05.10.2020 21:44
1.
program z1;
var a,b,c,x1, x2:real;
begin
writeln('введите коэффициенты А (отличное от нуля), В и С ');
readln(a,b,c);
if sqrt(b*b-4*a*c)>0 then
begin
x1:=(-b+sqrt(b*b-4*a*c))/2/a;
x2:=(-b-sqrt(b*b-4*a*c))/2/a;
writeln('x1=',x1,', x2=',x2);
end
else if sqrt(b*b-4*a*c)=0 then
begin
x1:=(-b+sqrt(b*b-4*a*c))/2/a;
writeln('x=',x1)
end
else writeln('уравнение не имеет корней');
end.

2.
program z1;
var b,c,x:real;
begin
writeln('введите коэффициенты B (отличное от нуля) и С ');
readln(b,c);
x:=-c/b;
writeln('x<',x);
end.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота