В
Все
Б
Биология
Б
Беларуская мова
У
Українська мова
А
Алгебра
Р
Русский язык
О
ОБЖ
И
История
Ф
Физика
Қ
Қазақ тiлi
О
Окружающий мир
Э
Экономика
Н
Немецкий язык
Х
Химия
П
Право
П
Психология
Д
Другие предметы
Л
Литература
Г
География
Ф
Французский язык
М
Математика
М
Музыка
А
Английский язык
М
МХК
У
Українська література
И
Информатика
О
Обществознание
Г
Геометрия
Гульжа1234
Гульжа1234
08.10.2021 05:54 •  Информатика

Написать программу для решения : сравнить первую и последнюю цифру натурального четырёхзначного числа n. на экране должен появиться запрос на ввод числа и результат решения , например 1) вводится число 1475, выводится «первая цифра меньше последней: 1< 5». 2) вводится число 3452, выводится «первая цифра больше последней: 3> 2». 3) вводится число 7457, выводится «первая цифра равна последней: 7=7»

Показать ответ
Ответ:
gc121
gc121
09.10.2020 13:25

var n:integer;

begin

write('Введите 4-х значное число: ');

readln(n);

if n div 1000 = n mod 10 then write('Первая цифра равна последней: ',n div 1000,'=',n mod 10)

else if n div 1000 > n mod 10 then write('Первая цифра больше последней: ',n div 1000,'>',n mod 10)

else write('Первая цифра меньше последней: ',n div 1000,'<',n mod 10)

end.

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота