В
Все
Б
Биология
Б
Беларуская мова
У
Українська мова
А
Алгебра
Р
Русский язык
О
ОБЖ
И
История
Ф
Физика
Қ
Қазақ тiлi
О
Окружающий мир
Э
Экономика
Н
Немецкий язык
Х
Химия
П
Право
П
Психология
Д
Другие предметы
Л
Литература
Г
География
Ф
Французский язык
М
Математика
М
Музыка
А
Английский язык
М
МХК
У
Українська література
И
Информатика
О
Обществознание
Г
Геометрия
петро26
петро26
09.03.2022 05:12 •  Информатика

Написать программу для решения следующей . в двумерном массиве, состоящем из целочисленных элементов, поменять местами в каждой строке наибольший и первый не принадлежащий интервалу (a, b) элементы. (паскаль)

Показать ответ
Ответ:
saschatuba
saschatuba
07.07.2020 18:00
Const
  m = 5; n = 10; a = 20; b = 80;
// Массив имеет размер mxn, интервал задан границами [a;b]
var
  i, j, max, outint, T, nT, nI: integer;
  Mas: array[1..m, 1..n] of integer;

begin
  Randomize;
  for i := 1 to m do
    for j := 1 to n do
      Mas[i, j] := Random(100);
  writeln('Исходный массив');
  for i := 1 to m do
  begin
    for j := 1 to n do
      write(Mas[i, j], ' ');
    writeln;
  end;
  Mas[i, j] := Random(100);
  for i := 1 to m do
  begin
    max := -1; // все элементы полагаются неотрицательными
    nI:=0;
    for j := 1 to n do
    begin
      T := Mas[i, j];
      if T > max then begin
        max := T; nT := j
      end;
      if nI = 0 then
        if (T <= a) or (T >= b) then nI := j
    end;
    if nI > 0 then begin
      T := Mas[i, nT]; Mas[i, nT] := Mas[i, nI]; Mas[i, nI] := T
    end
  end;
  writeln('Результирующий массив');
  for i := 1 to m do
  begin
    for j := 1 to n do
      write(Mas[i, j], ' ');
    writeln;
  end
end.

Пример выполнения программы в PascalABC.NET
Исходный массив
34 56 89 27 71 0 64 89 80 36
15 59 95 54 37 15 81 64 48 39
89 42 71 55 97 80 48 65 98 55
85 27 45 39 37 74 98 7 7 31
28 56 14 3 45 39 98 19 93 4
Результирующий массив
34 56 89 27 71 0 64 89 80 36
95 59 15 54 37 15 81 64 48 39
98 42 71 55 97 80 48 65 89 55
98 27 45 39 37 74 85 7 7 31
28 56 98 3 45 39 14 19 93 55
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота