В
Все
Б
Биология
Б
Беларуская мова
У
Українська мова
А
Алгебра
Р
Русский язык
О
ОБЖ
И
История
Ф
Физика
Қ
Қазақ тiлi
О
Окружающий мир
Э
Экономика
Н
Немецкий язык
Х
Химия
П
Право
П
Психология
Д
Другие предметы
Л
Литература
Г
География
Ф
Французский язык
М
Математика
М
Музыка
А
Английский язык
М
МХК
У
Українська література
И
Информатика
О
Обществознание
Г
Геометрия
close44
close44
12.10.2022 03:12 •  Информатика

Написать программу для решения квадратных уравнений при функций (main должна состоять только из их вызовов).

Показать ответ
Ответ:
хорошистка553
хорошистка553
27.05.2020 18:47

Вы не указали на каком языке Вам необходимо это решить. Поэтому выкладываю решение на C#.

using System;

using System.Collections.Generic;

using System.Linq;

using System.Text;

 

namespace ConsoleApplication1

{

class Program

{

static double[] Solve(double A, double B, double C, out bool Fail)

{

Fail = false;

double D = B * B - A * C;

double[] res = new double[2];

if (D >= 0)

{

res[0] = (Math.Sqrt(D) + B) / (2 * A);

res[1] = (Math.Sqrt(D) - B) / (2 * A);

}

else

{

Fail = true;

}

return res;

}

static void Main(string[] args)

{

bool Fail = false;

Console.WriteLine("Введите коэффициент при x^2");

double A = Double.Parse(Console.ReadLine());

Console.WriteLine("Введите коэффициент при x");

double B = Double.Parse(Console.ReadLine());

Console.WriteLine("Введите свободный коэффициент");

double C = Double.Parse(Console.ReadLine());

double[] res = Solve(A, B, C, out Fail);

if (Fail)

{

Console.Write("Дискриминант меньше нуля\n");

}

else

{

for (int i = 0; i < res.Length; i++)

{

Console.Write("x{0}={1} ", i, res[i]);

}

Console.Write("\n");

}

}

}

}

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота