В
Все
Б
Биология
Б
Беларуская мова
У
Українська мова
А
Алгебра
Р
Русский язык
О
ОБЖ
И
История
Ф
Физика
Қ
Қазақ тiлi
О
Окружающий мир
Э
Экономика
Н
Немецкий язык
Х
Химия
П
Право
П
Психология
Д
Другие предметы
Л
Литература
Г
География
Ф
Французский язык
М
Математика
М
Музыка
А
Английский язык
М
МХК
У
Українська література
И
Информатика
О
Обществознание
Г
Геометрия
janeair6994
janeair6994
30.11.2020 00:41 •  Информатика

Написать программу для нахождения простых чисел большого размера. для хранения цифр чисел использовать массивы. под большим размером подразумеваются 50-ти значные числа. использовать язык с

Показать ответ
Ответ:
vladshumigayoypa3u
vladshumigayoypa3u
28.11.2020 18:52

1. процессор

2. снимок не очень четкий не могу понять

3. Оперативная память

Объяснение:

1. Описание: Так называемый мозг компьютера, квадратной формы, легко вставляется в слот по ключам.

Функция: Основные задачи – обработка информации и управление всего аппаратного обеспечения компьютера.

2. Непонятно

3. Описание: вставляется также по ключам, до щилчка, относительно быстрая энергозависимая память компьютера с произвольным доступом, в которой осуществляются большинство операций обмена данными между устройствами. Является энергозависимой.

Функция – запоминать и хранить временную информацию, требующуюся процессору при выполнении операций.

0,0(0 оценок)
Ответ:
vasiaska234
vasiaska234
12.02.2020 20:44
//PascalABC.Net 3.0, сборка 1052
var
  d:single;
begin
  Write('Введите угол в градусах: '); Read(d);
  Writeln('Угол в радианах: ',DegToRad(d))
end.

Тестовое решение:
Введите угол в градусах: 57.3
Угол в радианах: 1.00007364807695

Вариант с формулой вместо функции:
//PascalABC.Net 3.0, сборка 1052
var
  d:single;
begin
  Write('Введите угол в градусах: '); Read(d);
  Writeln('Угол в радианах: ',Pi*d/180)
end.

Вариант, если не хочется использовать константу Pi:
//PascalABC.Net 3.0, сборка 1052
var
  d:single;
begin
  Write('Введите угол в градусах: '); Read(d);
  Writeln('Угол в радианах: ',ArcTan(1)*d/45)
end.

Вариант для тех, кто не помнит, что arctg(1)=π/4:
//PascalABC.Net 3.0, сборка 1052
const
  Pi=3.14;
var
  d:single;
begin
  Write('Введите угол в градусах: '); Read(d);
  Writeln('Угол в радианах: ',Pi*d/180)
end.

Тестовое решение для этого случая:
Введите угол в градусах: 57.3
Угол в радианах: 0.999566653357612

Как видно, из-за значения π, заданного с низкой точностью, снизилась и точность результата.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота