В
Все
Б
Биология
Б
Беларуская мова
У
Українська мова
А
Алгебра
Р
Русский язык
О
ОБЖ
И
История
Ф
Физика
Қ
Қазақ тiлi
О
Окружающий мир
Э
Экономика
Н
Немецкий язык
Х
Химия
П
Право
П
Психология
Д
Другие предметы
Л
Литература
Г
География
Ф
Французский язык
М
Математика
М
Музыка
А
Английский язык
М
МХК
У
Українська література
И
Информатика
О
Обществознание
Г
Геометрия
ravengan
ravengan
22.04.2023 12:24 •  Информатика

написать программу для машины Поста
1. Число k задано на ленте k метками. Увеличить число на единицу, если: 1) каретка находится где-то над массивом меток. 2) каретка находится где-то слева от массива.

2. На ленте задан массив меток. Увеличить его на два.

3. Два числа заданы на ленте двумя массивами меток. Сложить эти числа. Расстояние между массивами может быть: 1 метка; несколько меток.

Показать ответ
Ответ:
Olenkako2004
Olenkako2004
20.01.2020 17:54
Const Sz = 1000; var   a: array [1..Sz] of integer;  b: array [1..Sz] of integer;  c: array [1..Sz] of integer;  d: array [1..Sz] of integer;  M: integer;  N: integer;  i: integer;  k: integer;begin  read(M);  readln(N);  for i:=1 to N do begin    read(a[i]);    readln(b[i]);    if (a[i]<>0) then c[i]:=1 else c[i]:=0;    end;  for i:=1 to N do begin  if(c[i]<>0) then begin  for k:=1 to i do begin  if(d[k]=0) then d[i]:=1;  if (c[k]=i) then d[k]:=0;   end;   writeln(d[i])  end;end;end.
0,0(0 оценок)
Ответ:
QuAtTro271
QuAtTro271
24.08.2021 16:23

Вводим 200 Вывод 220

Объяснение:

var s, n, i: integer;

begin

for i:=200 to 250 do   //Создаём цикл, который будет прогонять

begin                           // значения S от 200 до 250

   s:=i;                          // логичнее начинать i c 200 т.к. while работает

   n := 100;                 // при условии, что s- 100 >= 100

   while s - n >= 100 do

   begin

        s := s + 20;

        n := n + 40;

   end;

writeln(i, ' ',s)     // вывод всех значений от 200 до 250

end;                   // выбираем нужный

end.

end.

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота