В
Все
Б
Биология
Б
Беларуская мова
У
Українська мова
А
Алгебра
Р
Русский язык
О
ОБЖ
И
История
Ф
Физика
Қ
Қазақ тiлi
О
Окружающий мир
Э
Экономика
Н
Немецкий язык
Х
Химия
П
Право
П
Психология
Д
Другие предметы
Л
Литература
Г
География
Ф
Французский язык
М
Математика
М
Музыка
А
Английский язык
М
МХК
У
Українська література
И
Информатика
О
Обществознание
Г
Геометрия
Ксюша10092007
Ксюша10092007
06.07.2022 05:15 •  Информатика

написать программу: Диапазон: [-10; 10]. Ввести массив A из 10 вещественных чисел, создать массив B из 21 вещественного числа с генератора псевдослучайных чисел. Реализовать функцию нахождения
номера позиции элемента массива с наименьшей дробной частью.

Показать ответ
Ответ:
katyasvk
katyasvk
23.10.2021 23:26
В бутылке минеральная вода. Сейчас стакан не стоит между чаем и молоком. Поставить стакан между бутылкой с минеральной водой и кружкой нельзя, так как тогда он будет стоять между минеральной водой, а должен стоять рядом с чаем и молоком. Значит, стакан можно поставить между кружкой и чашкой. Стакан оказывается в середине, значит, в нем кофе. Молоко не может быть в кружке, так как по соседству с молоком будет кофе и минеральная вода, а рядом с молоком должен быть квас. Значит, молоко в чашке. Так как по соседству с молоком должен быть квас, то в кувшине квас. 
ответ: в бутылке минеральная вода, в кружке чай, в чашке молоко, в стакане кофе, в кувшине квас.
0,0(0 оценок)
Ответ:
miliolia125
miliolia125
18.12.2021 06:09
// F#
open System
let anyNumberSymbol = "?"
let replaceSymbolOnIndex (str:string) (number:int) (index:int) =
    String.Format("{0}{1}{2}", str.Substring(0, index), number, str.Substring(index+1))
let rec getAllValues (valueStr:string) =
    let index = valueStr.IndexOf(anyNumberSymbol)
    if index > -1
        then
            let newStrings =
                [0..9]
                |> Seq.map (fun x -> replaceSymbolOnIndex valueStr x index)
            newStrings |> Seq.collect (fun x -> getAllValues x)
        else
            [valueStr] |> List.toSeq 
let getResults (numbers:string list) =
     List.nth numbers 0
        |> getAllValues
        |> Seq.map (fun firstNumber ->
              List.nth numbers 1
                |> getAllValues
                |> Seq.map (fun secondNumber ->
                      List.nth numbers 2
                        |> getAllValues
                        |> Seq.map (fun resultNumber ->
                            if Int32.Parse(firstNumber) + Int32.Parse(secondNumber) = Int32.Parse(resultNumber)
                                then [String.Format("{0} + {1} = {2}", firstNumber, secondNumber, resultNumber)]
                                else []
                        )
                        |> Seq.collect (fun x -> x)
                )
                |> Seq.collect (fun x -> x)
        )
        |> Seq.collect (fun x -> x)
        |> Seq.toArray
[<EntryPoint>]
let main argv =
    let inputString = System.Console.ReadLine()
    let numbers = inputString.Split('+', '=') |> Array.map (fun x -> x.Trim())
    if numbers.Length = 3
        then
            let results = getResults (numbers |> Array.toList)
            if results.Length > 0
                then Console.WriteLine(results |> Seq.fold (fun result x -> result + "\n" + x) "")
                else Console.WriteLine("No results")
            Console.ReadKey(true) |> ignore
            0
        else
            1
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота