В
Все
Б
Биология
Б
Беларуская мова
У
Українська мова
А
Алгебра
Р
Русский язык
О
ОБЖ
И
История
Ф
Физика
Қ
Қазақ тiлi
О
Окружающий мир
Э
Экономика
Н
Немецкий язык
Х
Химия
П
Право
П
Психология
Д
Другие предметы
Л
Литература
Г
География
Ф
Французский язык
М
Математика
М
Музыка
А
Английский язык
М
МХК
У
Українська література
И
Информатика
О
Обществознание
Г
Геометрия
НатЯ01771
НатЯ01771
31.07.2020 19:54 •  Информатика

Написать программу: дана число, если оно меньше 15, то нарисовать 100 эллипсов, иначе 100 линий

Показать ответ
Ответ:
nikita11111113
nikita11111113
10.03.2021 23:18
Обратим внимание, что при возведении натурального числа a в натуральную степень n последняя цифра результата определяется, как значение последней цифры d числа a, возведенного в степень n
Поскольку операция возведения в степень n сводится к умножению n раз числа самого на себя, то получая при очередном умножении многоразрядное число, мы можем снова принимать в расчет только его младшую цифру.
Это позволяет построить цикл на n умножений, каждый раз получая младшую цифру при операции mod.

var
  a:longint;
  n,d,i,p:integer;
begin
  Write('Введите натуральное число a: '); Read(a);
  Write('Введите натуральную степень n: '); Read(n);
  a:=a mod 10; p:=a;
  for i:=2 to n do
    begin a:=a*p; a:=a mod 10 end;
  Writeln('Последняя цифра равна ',a)
end.

Тестовое решение:
Введите натуральное число a: 154
Введите натуральную степень n: 9
Последняя цифра равна 4
0,0(0 оценок)
Ответ:
mila525784
mila525784
22.06.2022 10:08
1. \ 10^5, \ 3\cdot10^{-4}, \ 0.2\cdot10^7
2. 52 div 8 = 6 целое
2+6=8 целое
√8≈2.828 вещественное
trunc(2.828)=2 целое
15 mod 4=3 целое
3/3=1 целое
2-1=1 целое
ответ: 1, тип целое
3. Максимальное значение integer в языке Паскаль зависит от реализации. Стандарт языка определяет, что под переменную типа integer необходимо отвести объем памяти, достаточный для хранения значения 32767, т.е. 2^{15}-1. В связи с этим в ранних реализациях Паскаля под переменные типа integer отводилось 2 байта памяти. В современных реализациях под переменные этого типа отводится 4 байта, поэтому максимальное значение integer может достигать 2^{31}-1 или 2147483647.
4. Если надо сохранить целое число, большее в 10 раз максимального значения integer, то нужно для поинтересоваться а) Сколько байт отводится под integer? б) есть ли в данной реализации Паскаля целые числа, под хранение которых отводится большее число байт? Когда integer двухбайтовое, следует использовать четырехбайтное longint, а когда четырехбайтное - поинтересоваться наличием восьмибайтного типа int64.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота