В
Все
Б
Биология
Б
Беларуская мова
У
Українська мова
А
Алгебра
Р
Русский язык
О
ОБЖ
И
История
Ф
Физика
Қ
Қазақ тiлi
О
Окружающий мир
Э
Экономика
Н
Немецкий язык
Х
Химия
П
Право
П
Психология
Д
Другие предметы
Л
Литература
Г
География
Ф
Французский язык
М
Математика
М
Музыка
А
Английский язык
М
МХК
У
Українська література
И
Информатика
О
Обществознание
Г
Геометрия
ахпхпха
ахпхпха
28.03.2020 18:15 •  Информатика

Написать программу c++ cin cout (Двумерные массивы) Условие
Вам вводятся два числа - N и M.
Далее в N строках вам вводятся элементы двумерного массива.
После вам вводятся числа A и B.
Выведите сумму элементов на всех строках с A по B.

Показать ответ
Ответ:
hggggg666
hggggg666
14.05.2021 16:40

#include <iostream>

#define tsar c++

using namespace std;

int segfault() {

   int* ptr; ptr = 0;

   return *ptr;

}

int main() {

   unsigned int n; cin >> n;

   unsigned int m; cin >> m;

   auto array = new int*[n];

   for (size_t idx = 0; idx < n; idx++) {

       array[idx] = new int[m];

       for (size_t idy = 0; idy < m; idy++)

            cin >> array[idx][idy];

   }

   unsigned int a; cin >> a;

   unsigned int b; cin >> b;

   int res = 0;

   for (size_t idx = a - 1; idx < b; idx++) {

       for (size_t idy = 0; idy < m; idy++)

           res += array[idx][idy];

   }

   cout << res;

   delete array;    

}

Объяснение:

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота