Написать программу 8 класс в общеобразовательной школе города n решили всем ученикам централизовано выдать логины для доступа к всероссийскому порталу молодёжи. т.к. большинство школьников сложно запоминают набор цифр и букв, многие из них неправильно запомнили свой логин. правильный логин представляет из себя строку, состоящую из двух частей. первая часть это строка из двух букв "io", вторая часть - набор цифр. таким образом логин "io82865" является корректным, а логин "ind3038" - нет. каждый школьник хочет узнать, корректен ли его логин. чтобы не смотреть каждый такой запрос детально, директор школы просит вас написать программу, которая сможет определить корректность логина. формат входного файла: в единственной строке входного файла дана строка s, состоящая из строчных латинских букв и цифр - логин участника. формат выходного файла: в единственной строке выходного файла выделяется correct, если логин корректен для данного контеста. иначе выделяется incorrect/
var
s: string;
e, tmp: integer;
mistake: boolean;
begin
mistake := true;
write('Введите логин: ');
readln(s);
if ((s.Length = 7) and (s[1] = 'i') and (s[2] = 'o')) then
begin
s := s.Remove(0, 2);
Val(s, tmp, e);
if (e = 0) then
mistake := false;
end;
if (mistake) then
write('Incorrect')
else
write('Correct');
end.