В
Все
Б
Биология
Б
Беларуская мова
У
Українська мова
А
Алгебра
Р
Русский язык
О
ОБЖ
И
История
Ф
Физика
Қ
Қазақ тiлi
О
Окружающий мир
Э
Экономика
Н
Немецкий язык
Х
Химия
П
Право
П
Психология
Д
Другие предметы
Л
Литература
Г
География
Ф
Французский язык
М
Математика
М
Музыка
А
Английский язык
М
МХК
У
Українська література
И
Информатика
О
Обществознание
Г
Геометрия
Ibrolya
Ibrolya
08.08.2020 15:07 •  Информатика

Написать программу, 25 в офисе, где работает программист петр, установили кондиционер нового типа. этот кондиционер отличается особой простотой в . у кондиционера есть всего лишь два параметра: желаемая температура и режим работы. кондиционер может работать в следующих четырех режимах: 1 – «freeze» — охлаждение. в этом режиме кондиционер может только уменьшать температуру. если температура в комнате и так не больше желаемой, то он выключается. 2 – «heat» — нагрев. в этом режиме кондиционер может только увеличивать температуру. если температура в комнате и так не меньше желаемой, то он выключается. 3 – «auto» — автоматический режим. в этом режиме кондиционер может как увеличивать, так и уменьшать температуру в комнате до желаемой. 4 – «fan» — вентиляция. в этом режиме кондиционер осуществляет только вентиляцию воздуха и не изменяет температуру в комнате. кондиционер достаточно мощный, поэтому при настройке на правильный режим работы он за час доводит температуру в комнате до желаемой. требуется написать программу, которая по заданной температуре в комнате t-room, установленным на кондиционере желаемой температуре t-cond и номеру режима работы определяет температуру, которая установится в комнате через час

Показать ответ
Ответ:
лерчик1253
лерчик1253
27.12.2020 07:34

1)

a = [12,32,51,2,5,-10,-20,23,-23] # задаете любой массив

a.sort()

minim = 0

maxim = 0

for i in range(len(a)):

   if a[i] % 2 == 0:

       minim = a[i]

       break

a = list(reversed(a))

for i in range(len(a)):

   if a[i] % 2 == 0:

       maxim = a[i]

       break

print(minim)

print(maxim)

2)

a = [12,32,51,2,1,-10,-20,21,-23]

a.sort()

minim = 0

maxim = 0

for i in range(len(a)):

   if a[i] % 10 == 5:

       minim = a[i]

       break

a = list(reversed(a))

for i in range(len(a)):

   if a[i] % 10 == 5:

       maxim = a[i]

       break

if minim == 0 and maxim == 0:

   print('No')

else:

   print(minim)

   print(maxim)

0,0(0 оценок)
Ответ:
skachkov1562
skachkov1562
05.04.2022 13:35

Сначала нужно сделать табулирование заданной функции, то есть таблицу, где каждому значению x и y будет соответствовать вычисленное значение z (рисунок 1). Я просто ввел в столбец x значения от -2 до 2 с шагом 0,2 (шаг выбрал сам, потому что в условии он не задан), также ввел значения в столбец y и в столбец z ввел формулу.

В Excel есть поверхностная диаграмма. Ее можно добавить, найдя на вкладке "Вставка" в группе "Диаграмма" соответствующую кнопку. Нам нужна "Бесцветная объемная поверхностная".

Если мы добавим диаграмму по созданной таблице, результат нас не устроит. Необходимо нашу таблицу превратить в формат полигональной сетки (рисунок 2), то есть для каждого x и каждого y вычисляется z, как в таблице умножения (рисунок 3).

Теперь нужно выделить только диапазон со значениями z и добавить диаграмму. Полученная диаграмма изображена на рисунке 4.

К ответу прикреплена рабочая книга Excel с выполненным заданием.


Как построить тот график поверхностей в экселе?
Как построить тот график поверхностей в экселе?
Как построить тот график поверхностей в экселе?
Как построить тот график поверхностей в экселе?
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота