В
Все
Б
Биология
Б
Беларуская мова
У
Українська мова
А
Алгебра
Р
Русский язык
О
ОБЖ
И
История
Ф
Физика
Қ
Қазақ тiлi
О
Окружающий мир
Э
Экономика
Н
Немецкий язык
Х
Химия
П
Право
П
Психология
Д
Другие предметы
Л
Литература
Г
География
Ф
Французский язык
М
Математика
М
Музыка
А
Английский язык
М
МХК
У
Українська література
И
Информатика
О
Обществознание
Г
Геометрия
22031982golub
22031982golub
28.07.2020 00:13 •  Информатика

Написать одну программу для вычисления трех логических переменных: rez1, rez2, rez3. используя следующие данные. Три вычисления в одной программе.Даны значения целочисленных переменных: а = 10, b = 20. Чему будет равно значение логической переменной rez после выполнения операции присваивания? а) rez:=(а=10) or (b>10) б) rez:=(а>5) and (b>5) and (a 20)

Показать ответ
Ответ:
ValeriaBezzubik
ValeriaBezzubik
12.12.2020 08:39

program z1;

var a,b: integer;

rez1, rez2, rez3: boolean;

begin

a := 10;

b := 20;

rez1:=(a=10) or (b>10);

rez2:=(a>5) and (b>5) and (a>20);

rez3:=(not(a<15)) or (b>20);

writeln('rez1 = ',rez1,'     rez2 = ',rez2,'     rez3 = ',rez3)

end.

Объяснение:

Объявляем переменные rez1, rez2, rez3 - логическими.

Пишем условия

Выводим на экран

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота