Написать на паскале дано n пицц пиццу резать нельзя ! если распределить пиццы поровну среди м друзей , то по скольку пицц получит каждый друг и сколько пицц окажутся не распределенными ? программа получает на вход два натуральных числа n и m , при чем n > m. n не превосходит 10 9 программа должна вывести два числа- сколько пицц достанется каждому другу и сколько пицц останется не распределенными через пробел
До нельзя просто. div находит целое число от деления, mod — остаток. Путём деления и находим, кто сколько пицц скушает =)
program Pizza2friends;
var N,M:integer;
begin
writeln('Введите количество пицц');
read(N);
writeln('Введите количество друзей');
read(M);
if N > M then
writeln('У каждого друга будет ',N div M,' пицц. Останется ',N mod M,' ничьих пицц.')
else writeln('Пицц должно быть больше, чем друзей');
end.