Войти
Регистрация
Спроси ai-bota
В
Все
Б
Биология
Б
Беларуская мова
У
Українська мова
А
Алгебра
Р
Русский язык
О
ОБЖ
И
История
Ф
Физика
Қ
Қазақ тiлi
О
Окружающий мир
Э
Экономика
Н
Немецкий язык
Х
Химия
П
Право
П
Психология
Д
Другие предметы
Л
Литература
Г
География
Ф
Французский язык
М
Математика
М
Музыка
А
Английский язык
М
МХК
У
Українська література
И
Информатика
О
Обществознание
Г
Геометрия
Показать больше
Показать меньше
AdelkaTiVi
29.06.2022 04:39 •
Информатика
Написать код программы с использованием цикла while на pascalabc. определить все значения при условии δx=1,005 (шаг)
Показать ответ
Ответ:
sodemAN2
28.09.2020 13:21
Const
x0 = 1.909;
x1 = 6.23;
step = 1.005;
t=10;
var
i: real;
begin
i:=0;
while i<(x1-x0)/step do
begin
writeln('a(', x0+i, ') = ', sqrt(1+sqr(x0+i))+t);
i:=i+step;
end;
if (x0+i-step)<(x1) then writeln('a(', x1, ') = ', sqrt(1+sqr(x1))+t)
end.
0,0
(0 оценок)
Популярные вопросы: Информатика
Kotvo4cah
04.06.2023 05:05
Перевести число 105 из десятичной системы в двуичную систему счисления...
valentinastarod
04.06.2023 05:05
Перевести число 723 из десятичной систем счисления в шестнадцату систем счисления...
MiaDakota
08.11.2022 11:29
дополнить программу Нужно чтобы после окончания работы программа спросила : Желаете ли вы закончить работу? Program ploshad; var a,b,c:real; begin write( Введите значение a= );...
Ivankozyr69gmail
30.06.2020 01:42
1. Объясните особенности линейных алгоритмов. 2. Какие операторы используются для ввода и вывода в модульной программе? 3. Какие операторы используются для ввода и вывода данных...
XxXBulykXxX
25.12.2021 22:17
Файл длительностью 2,5 мин при глубине кодирования 16 бит, стерео, занимает на диске 18 Мб. Определите частоту дискретизации, с которой он записан...
zoology1g
15.05.2021 17:46
САМОЕ НИЗКОЕ МЕСТО НА РУССКОЙ РАВНИНЕ: 1. ПЕЧОРСКАЯ НИЗМ. 2. ОКСКО – ДОНСКАЯ РАВНИНА 3. ПРИКАСПИЙСКАЯ НИЗМ 2)ПРИРОДА РУССКОЙ РАВНИНЫ: 1. ПОЧТИ НЕ ИЗМЕНЕНА ЧЕЛОВЕКОМ 2. ИЗМЕНЕНА...
danilasen34
12.01.2020 04:56
Надо решить эту карточку...
Андріана1323
24.10.2020 19:48
Кратко в письменной форме ответить на во В чем видят литературоведы выдающиеся художественные достижения Толстого? 2. Какие стороны творчества Толстого особенно ценят зарубежные...
11cat13
16.01.2023 14:06
Написать программу, которая выводит таблицу значений функции y, которая на разных интервалах меняет свое значение (х меняется с шагом 1)....
solopova08
03.02.2021 11:56
1Выпишите граматическую основу 2 Выпишите осложнения если оно есть 3 охарактеризуй предложения 1Илья несмотря на вмешательство соскучился по своему усмотрению 2 Васька сходила...
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota
Оформи подписку
О НАС
О нас
Блог
Карьера
Условия пользования
Авторское право
Политика конфиденциальности
Политика использования файлов cookie
Предпочтения cookie-файлов
СООБЩЕСТВО
Сообщество
Для школ
Родителям
Кодекс чести
Правила сообщества
Insights
Стань помощником
ПОМОЩЬ
Зарегистрируйся
Центр помощи
Центр безопасности
Договор о конфиденциальности полученной информации
App
Начни делиться знаниями
Вход
Регистрация
Что ты хочешь узнать?
Спроси ai-бота
x0 = 1.909;
x1 = 6.23;
step = 1.005;
t=10;
var
i: real;
begin
i:=0;
while i<(x1-x0)/step do
begin
writeln('a(', x0+i, ') = ', sqrt(1+sqr(x0+i))+t);
i:=i+step;
end;
if (x0+i-step)<(x1) then writeln('a(', x1, ') = ', sqrt(1+sqr(x1))+t)
end.