В
Все
Б
Биология
Б
Беларуская мова
У
Українська мова
А
Алгебра
Р
Русский язык
О
ОБЖ
И
История
Ф
Физика
Қ
Қазақ тiлi
О
Окружающий мир
Э
Экономика
Н
Немецкий язык
Х
Химия
П
Право
П
Психология
Д
Другие предметы
Л
Литература
Г
География
Ф
Французский язык
М
Математика
М
Музыка
А
Английский язык
М
МХК
У
Українська література
И
Информатика
О
Обществознание
Г
Геометрия
nitkind
nitkind
05.01.2023 13:23 •  Информатика

Написать код программы , который в последовательности натуральных чисел определяет максимальное число. Программа получает на вход количество чисел в последовательности, а затем сами числа.

Показать ответ
Ответ:
Arianna779
Arianna779
14.10.2020 13:33

program z1;

var a, i, n, max: integer;

begin

max:=0;

write ('Введите количество чисел в последовательности ');

readln (n);

for i:=1 to n do

begin

write ('Введите натуральное число ');

readln (a);

if a > max then max:=a

end;

writeln('Максимальное число в последовательности ',max)

end.

Объяснение:

Т.к. программа будет получать на вход натуральные числа, то первоначальным значением для переменной max можно взять 0.

Он не является натуральным числом, но все натуральные числа больше него.

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота