Написать код на C
Составьте программу, которая бы выполняла следующие действия:
1) принять с клавиатуры два целых числа (d1 - деленное и d2 - делитель)
2) проверить их на корректность: если d2 == 0, либо одновременно d1 == d2 == 0 - вывести соответствующие сообщение и повторить ввод (вернуться на п.1)
3) рассчитать долю и остаток от их деления;
4) в зависимости от того, чему равен остаток - вывести на экран d2 раз долю и в конце - остаток (один раз) с различных циклов:
- если остаток == 1 - цикла с известным количеством повторений (for)
- если остаток == 2 - цикла с условием (while)
- если остаток == 3 - цикла с постусловием (do-while)
- в противном случае - по повторно ввести деленное и делитель (переход на п.1)
const
m = 10;
var
t: array[1..m] of integer;
i, n, nm, sm: integer;
begin
//Заполняем массив сл.числами и подсчитываем
//количество элементов и среднее арифметическое
//согласно условию задачи
for i := 1 to m do
begin
t[i] := random(-20, 20);write(t[i]:4);
if (i > 1) and (i <= m) then
if t[i] > t[i - 1] then n := n + 1
else if t[i] < t[i - 1] then begin
sm := sm + t[i];nm := nm + 1;
end;
end;
writeln;
writeln('число элементов больших предыдущего = ', n);
writeln('ср. арифметическое элементов меньших предыдущего = ', sm / nm);
end.
Тестовое решение:
6 13 19 8 -19 -11 -20 -15 -19 -13
число элементов, больших предыдущего = 5
среднее арифметическое элементов, меньших предыдущего = -12.5
begin
writeln("введите количество метров пробегания жирафа");
read(y1);
writeln("введите, за сколько секунд он должен пробежать");
read(x1);
writeln("введите количество метров пробегания зайца");
read(y2);
writeln("введите, за сколько секунд он должен пробежать");
read(x2);
v1:=y1/x1;
v2:=y2/x2;
if v1>v2 then
begin
writeln("жираф чемпион");
end
else if v1<v2 then
begin
writeln("заяц чемпион");
end
else
begin
writeln("победила дружба);
end;
end;