В
Все
Б
Биология
Б
Беларуская мова
У
Українська мова
А
Алгебра
Р
Русский язык
О
ОБЖ
И
История
Ф
Физика
Қ
Қазақ тiлi
О
Окружающий мир
Э
Экономика
Н
Немецкий язык
Х
Химия
П
Право
П
Психология
Д
Другие предметы
Л
Литература
Г
География
Ф
Французский язык
М
Математика
М
Музыка
А
Английский язык
М
МХК
У
Українська література
И
Информатика
О
Обществознание
Г
Геометрия

написать две задачи на Python: 1. В области 12 районов. Известны количество жителей (в тысячах человек) и площадь (в км2) каждого района. Определить среднюю плотность населения по области в целом. Решить задачу используя циклическую конструкцию for.
2. 2.Мой богатый дядюшка подарил мне один доллар в мой первый день рождения. В каждый день рождения он удваивал свой подарок и прибавлял к нему столько долларов, сколько лет мне исполнилось. Написать программу, указывающую, к какому дню рождения подарок превысит 100$. Решить задачу используя циклическую конструкцию while.

Показать ответ
Ответ:
lianabalkoewa
lianabalkoewa
30.09.2022 14:42
Анна Брусникина
Тамара Черникина
Галина Морошкина
Ирина Клубникина    и
Полина  Малинина
 
с начала про Ирину: с условия мы понимаем что она не является ни малининой, ни черникиной, ни морошкиной(так как все предположения подруг оказались неверными, а первое место заняла морошкина, вывод морошкина - не Ирина)
Анна - ну тут все ясно, вычеркиваем из ее столбца малинину, клубникину, черникину, морошкину, а Анна у нас Брусникина (значит никто из девочек больше не может быть клубникиной, и тут выясняем что Ирина у нас клубничку любит, опять же никто из девочек не может быть больше клубникиной.)
Полина у нас не может быть Морошкиной, это мы ясно видим, но возвратимся к неверным предположениям, 4 место в этих предположениях занимает... Черникина. Вычитаем эти 2 фамилие из общей массы. Полина получается у нас малининой.
С тех же самых ошибочных предположений находим что Тамара черникина, а Галина Морошкина
надеюсь

 
0,0(0 оценок)
Ответ:
ayvazova2010
ayvazova2010
24.02.2021 16:13
{ ответ дан на языке Pascal }
// 1-ая задача
PROGRAM Solution(INPUT, OUTPUT);

VAR
  n1, n2, n3: INTEGER;

BEGIN
  WRITE('Введите 3 числа: ');
  READ(n1, n2, n3);

  IF n1 < 0
  THEN n1 := n1 * n1 * n1 * n1
  ELSE n1 := n1 * n1;

  IF n2 < 0
  THEN n2 := n2 * n2 * n2 * n2
  ELSE n2 := n2 * n2;

  IF n3 < 0
  THEN n3 := n3 * n3 * n3 * n3
  ELSE n3 := n3 * n3;

  WRITELN(n1);
  WRITELN(n2);
  WRITELN(n3);
END.

//2-ая задача
PROGRAM Solution(INPUT, OUTPUT);

VAR
  num: INTEGER;
  n1, n2, n3: INTEGER;

BEGIN
  WRITE('Введите 3-значное число: ');
  READ(num);

  n1 := (num DIV 100);
  n2 := (num MOD 100 MOD 10);
  n3 := (num MOD 100 DIV 10);
  IF(num * num) = (n1 * n1 * n1) + (n2 * n2 * n2) + (n3 * n3 * n3)
  THEN WRITELN('Равен')
  ELSE WRITELN('Не равен');
END.

//3-я задача
PROGRAM Solution(INPUT, OUTPUT);

VAR
  num: INTEGER;

BEGIN
  WRITE('Введите месяц (1 - 12): ');
  READ(num);
  CASE num
  OF
    1: WRITELN('Январь');
    2: WRITELN('Февраль');
    3: WRITELN('Март');
    4: WRITELN('Апрель');
    5: WRITELN('Май');
    6: WRITELN('Июнь');
    7: WRITELN('Июль');
    8: WRITELN('Август');
    9: WRITELN('Сентябрь');
    10: WRITELN('Октябрь');
    11: WRITELN('Ноябрь');
    12: WRITELN('Декабрь');
  END;
END.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота