В
Все
Б
Биология
Б
Беларуская мова
У
Українська мова
А
Алгебра
Р
Русский язык
О
ОБЖ
И
История
Ф
Физика
Қ
Қазақ тiлi
О
Окружающий мир
Э
Экономика
Н
Немецкий язык
Х
Химия
П
Право
П
Психология
Д
Другие предметы
Л
Литература
Г
География
Ф
Французский язык
М
Математика
М
Музыка
А
Английский язык
М
МХК
У
Українська література
И
Информатика
О
Обществознание
Г
Геометрия
annagj200430
annagj200430
04.01.2021 00:02 •  Информатика

Написать алгоритм данной программы в виде блок схем и на естественном языке. написать программу, которая выводит таблицу значений функ- ции y= –2,4x2 + 5x – 3 в диапазоне от –2 до 2 с шагом 0,5.

Показать ответ
Ответ:
адевале1
адевале1
29.07.2020 12:17
// PascalABC.NET 3.2, сборка 1382 от 06.02.2017
// Внимание! Если программа не работает, обновите версию!

begin
  var n:=ReadInteger('Количество строк (столбцов) в массиве:');
  Writeln('*** Исходный массив [',n,',',n,'] ***');
  var a:=MatrRandom(n,n,-10,10);
  a.Println(4); Writeln(5*a.ColCount*'-');
  var k,l:integer;
  Write('Введите L,K: '); Read(l,k);
  var lim:=a[l-1,k-1];
  var s:=a.Rows.SelectMany(x->x).Where(x->x<lim).Sum;
  Writeln('Искомая сумма равна ',s)
end.

Пример
Количество строк (столбцов) в массиве: 6
*** Исходный массив [6,6] ***
  -4  -8  -7  -3  -6  -4
   2  -9   1   9  -6   6
  -9  -2  -8  -3  -1  -4
  -1  -9  -3  -7   3  -3
   5   9  -6   8  -1 -10
  -1  -1  -5  -8  -9   4

Введите L,K: 2 3
Искомая сумма равна -138
0,0(0 оценок)
Ответ:
Мика7477u
Мика7477u
20.03.2021 11:29

1

Задание 5 № 10383

У исполнителя Альфа две команды, которым присвоены номера:

1. прибавь 1;

2. умножь на b

(b — неизвестное натуральное число; b ≥ 2).

Выполняя первую из них, Альфа увеличивает число на экране на 1, а выполняя вторую, умножает это число на b. Программа для исполнителя Альфа — это последовательность номеров команд. Известно, что программа 11211 переводит число 6 в число 82. Определите значение b.

Решение · Поделиться · Сообщить об ошибке Задание 5 № 10384

У исполнителя Альфа две команды, которым присвоены номера:

1. прибавь 1;

2. умножь на b

(b — неизвестное натуральное число; b ≥ 2).

Выполняя первую из них, Альфа увеличивает число на экране на 1, а выполняя вторую, умножает это число на b. Программа для исполнителя Альфа — это последовательность номеров команд. Известно, что программа 11211 переводит число 3 в число 62. Определите значение b.

Решение · Поделиться · Сообщить об ошибке Задание 5 № 10385

У исполнителя Бета две команды, которым присвоены номера:

1. прибавь 2;

2. умножь на b

(b — неизвестное натуральное число; b ≥ 2).

Выполняя первую из них, Бета увеличивает число на экране на 2, а выполняя вторую, умножает это число на b. Программа для исполнителя Бета — это последовательность номеров команд. Известно, что программа 12111 переводит число 7 в число 51. Определите значение b.

Решение · Поделиться · Сообщить об ошибке Задание 5 № 10386

У исполнителя Бета две команды, которым присвоены номера:

1. прибавь 2;

2. умножь на b

(b — неизвестное натуральное число; b ≥ 2).

Выполняя первую из них, Бета увеличивает число на экране на 2, а выполняя вторую, умножает это число на b. Программа для исполнителя Бета — это последовательность номеров команд. Известно, что программа 11121 переводит число 4 в число 72. Определите значение b.

Решение · Поделиться · Сообщить об ошибке Задание 5 № 10387

У исполнителя Гамма две команды, которым присвоены номера:

1. прибавь 3;

2. умножь на b

(b — неизвестное натуральное число; b ≥ 2).

Выполняя первую из них, Гамма увеличивает число на экране на 3, а выполняя вторую, умножает это число на b. Программа для исполнителя Гамма — это последовательность номеров команд. Известно, что программа 11211 переводит число 1 в число 97. Определите значение b.

Решение · Поделиться · Сообщить об ошибке Задание 5 № 10388

У исполнителя Гамма две команды, которым присвоены номера:

1. прибавь 3;

2. умножь на b

(b — неизвестное натуральное число; b ≥ 2).

Выполняя первую из них, Гамма увеличивает число на экране на 3, а выполняя вторую, умножает это число на b. Программа для исполнителя Гамма — это последовательность номеров команд. Известно, что программа 11121 переводит число 3 в число 75. Определите значение b.

Решение · Поделиться · Сообщить об ошибке Задание 5 № 10389

У исполнителя Омега две команды, которым присвоены номера:

1. прибавь 4;

2. умножь на b

(b — неизвестное натуральное число; b ≥ 2).

Выполняя первую из них, Омега увеличивает число на экране на 4, а выполняя вторую, умножает это число на b. Программа для исполнителя Омега — это последовательность номеров команд. Известно, что программа 12111 переводит число 9 в число 77. Определите значение b.

Решение · Поделиться · Сообщить об ошибке Задание 5 № 10390

У исполнителя Сигма две команды, которым присвоены номера:

1. прибавь 1;

2. раздели на b

(b — неизвестное натуральное число; b ≥ 2).

Выполняя первую из них, Сигма увеличивает число на экране на 1, а выполняя вторую, делит это число на b. Программа для исполнителя Сигма — это последовательность номеров команд. Известно, что программа 12111 переводит число 63 в число 11. Определите значение b.

Решение · Поделиться · Сообщить об ошибке Задание 5 № 10391

У исполнителя Сигма две команды, которым присвоены номера:

1. прибавь 1;

2. раздели на b

(b — неизвестное натуральное число; b ≥ 2).

Выполняя первую из них, Сигма увеличивает число на экране на 1, а выполняя вторую, делит это число на b. Программа для исполнителя Сигма — это последовательность номеров команд. Известно, что программа 12111 переводит число 50 в число 20. Определите значение b.

Решение · Поделиться · Сообщить об ошибке Задание 5 № 10392

У исполнителя Альфа две команды, которым присвоены номера:

1. прибавь 2;

2. раздели на b

(b — неизвестное натуральное число; b ≥ 2).

Выполняя первую из них, Альфа увеличивает число на экране на 2, а выполняя вторую, делит это число на b. Программа для исполнителя Альфа — это последовательность номеров команд. Известно, что программа 12111 переводит число 47 в число 13. Определите значение b.

Решение · Поделиться · Сообщить об ошибке Объяснение:

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота