В
Все
Б
Биология
Б
Беларуская мова
У
Українська мова
А
Алгебра
Р
Русский язык
О
ОБЖ
И
История
Ф
Физика
Қ
Қазақ тiлi
О
Окружающий мир
Э
Экономика
Н
Немецкий язык
Х
Химия
П
Право
П
Психология
Д
Другие предметы
Л
Литература
Г
География
Ф
Французский язык
М
Математика
М
Музыка
А
Английский язык
М
МХК
У
Українська література
И
Информатика
О
Обществознание
Г
Геометрия
jvdvzkris
jvdvzkris
16.02.2020 17:46 •  Информатика

Надо составить программу на языке Паскаль АБС для получения таблицы истинности. Для этого надо A и B присвоить 0 to 1 do.(цикл for) Надо получить таблицу истинностьи A and B и not A

Показать ответ
Ответ:
shapovalovalyubochka
shapovalovalyubochka
08.01.2021 08:35

var A,B,C:boolean;

function f(C,B,A:boolean):boolean;

begin

f:=((A and C) and(not B))and(B or A);  

end;

begin

writeln('C':7,'B':7,'A':7,'F':7);

for C:=false to true do

for B:=false to true do

for A:=false to true do

writeln(C:7,B:7,A:7,f(C,B,A):7);

readln;

end.

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота