В
Все
Б
Биология
Б
Беларуская мова
У
Українська мова
А
Алгебра
Р
Русский язык
О
ОБЖ
И
История
Ф
Физика
Қ
Қазақ тiлi
О
Окружающий мир
Э
Экономика
Н
Немецкий язык
Х
Химия
П
Право
П
Психология
Д
Другие предметы
Л
Литература
Г
География
Ф
Французский язык
М
Математика
М
Музыка
А
Английский язык
М
МХК
У
Українська література
И
Информатика
О
Обществознание
Г
Геометрия
annyta290802p012i5
annyta290802p012i5
02.09.2022 00:26 •  Информатика

Надо составить программу на паскале, которая будет писать все положительные значения f(x) на интервале от a до b с шагом h. Функция F(x) = 2cos(x)-1


Надо составить программу на паскале, которая будет писать все положительные значения f(x) на интерва

Показать ответ
Ответ:
artemssh2
artemssh2
20.06.2021 19:41

Program trig;

var a,b,H:real;

Function F(n:real):real;

begin

F:=2*cos(n)-1;  

end;

begin

write('Введите шаг: ');

readln(H);

write('Введите интервал: ');

readln(a,b);

writeln('x    F(x)');

writeln('');

while a<=b do begin

 if(F(a) > 0) then writeln(a:0:2,'  ',F(a):0:2);

 a:=a+H;

 end;

end.

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота