Надо решить двумерным массивом! даны два числа n и m. создайте двумерный массив [n][m] и заполните его по следующим правилам: числа, стоящие в строке 0 или в столбце 0 равны 1 (a[0][j]=1, a[i][0]=1). для всех остальных элементов массива a[i][j]=a[i-1][j]+a[i][j-1], то есть каждый элемент равен сумме двух элементов, стоящих слева и сверху от него. входные данные программа получает на вход два числа n и m. выходные данные выведите данный массив. примеры входные данные 3 3 выходные данные 1 1 1 1 2 3 1 3 6
N = 3;
M = 4;
Var
A:array[0..N-1,0..M-1] of integer;
i,j,k:integer;
Begin
For i:= 0 to N-1 do
For j:= 0 to M-1 do
if i*j = 0 then A[i,j]:=1;
if M>N then k:=M
else k:=N;
For k:= 1 to k-1 do
For i:= 1 to N-1 do
For j:= 1 to M-1 do
if (i = k)or(j = k) then
A[i,j]:=A[i-1,j]+A[i,j-1];
For i:= 0 to N-1 do
For j:= 0 to M-1 do
Write(A[i,j],' ');
End.